The forum

PoL Configuration settings misbehaving

In "Display" remembers "enabled\0" instead of just "enabled"

Author Replies
Deuxis Thursday 29 January 2015 at 18:06
DeuxisAnonymous

Hello, I'm running PlayOnLinux 4.2.2 on fairly fresh default install of Linux Mint 17.1 32bit and I have encountered a few weird problems. One of them is with saving the configuration. When I try to configure "Display" tab of my "SteamPoL" virtual drive, any settings I change get saved with \0 at the end, making PoL not read them properly and bug out my games. So for example I would try to set video memory size to 1024, exit the config, return to it and see "1024\0" in that field. This occurs with all virtual drives and all "Display" settings, making it impossible for me to play for example War Thunder which requires enabled GLSL support.

 

Another, possibly related issue is that I cannot "open a shell" in the config, it plainly refuses to work. I click the button and nothing happens.

 

I tried reinstalling PlayOnLinux with standard atp-get commands, and it achieved nothing. I suspect I'll just have to remove the config and restart it or something and it'll all fix itself, but frankly, I have no idea which config and where is it. Also this serves as a kinda-bug report.

Ronin DUSETTE Thursday 29 January 2015 at 19:09
Ronin DUSETTE
Admin

Try to upgrade POL to the newest version (check our Download section). Sounds like a unicode error, I think. I have never seen that, so that is a guess. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
loggod Sunday 22 March 2015 at 22:20
loggodAnonymous

i have this issue too that the settings in the display dialog don't get saved at all, allways get resettet and/or every entry gets a trailing "/0". very annoying sad

 

* You do know that Warthunder is available as native Linux client on steam? install steam and check it out laugh

petch Sunday 22 March 2015 at 22:56
petch
Developer

You managed to give no technical info, that could be used to pinpoint the issue...

 

loggod Monday 23 March 2015 at 0:12
loggodAnonymous

Ehm what info do you need?

its not a problem with a game or a particular wine version etc. ..its just that settings made in the pol config display tab don't get saved etc. and/or messed up. f.e if i enter 2048MB under video Memory size it gets resettet to default, once i close and re open the display tab. Or it shows "2048MB/0" after reopening the display tab. So tuning a wineprefix doesnt work at all for me. it also doesnt work with the msic. tab. i cant set mousewrap override to enable. it gets resettet to default also. I am running POL 4.2.6

 

Tell me what do you need. Sorry for my english.

greetz

 loggod

Edited by loggod

petch Monday 23 March 2015 at 0:33
petch
Developer

It's hard to say what's relevant, since the problem is not understood, but let's say

- Linux distribution (and release)

- Locale (the output of the

locale

command would be great)

- the version of wxPython (2.8 or 3.0). Again the output of

python -c 'import wxversion; print wxversion.getInstalled()'

would be great

Edited by petch

loggod Monday 23 March 2015 at 0:40
loggodAnonymous

i am german, so the output of locale looks like this:

LANG=de_DE.utf8
LC_CTYPE="de_DE.utf8"
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE="de_DE.utf8"
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES="de_DE.utf8"
LC_PAPER=de_DE.UTF-8
LC_NAME="de_DE.utf8"
LC_ADDRESS="de_DE.utf8"
LC_TELEPHONE="de_DE.utf8"
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION="de_DE.utf8"
LC_ALL=

>i found something. if i open the user.reg file in the wineprefix it looks like this f.e

[Software\\Wine\\Direct3D] 1427063970
"DirectDrawRenderer"="opengl/0"
"StrictDrawOrdering"="enabled/0"
"UseGLSL"="enabled/0"
"VideoMemorySize"="2048/0"

if i remove the trailing "/0" and save the txt file, the settings get displayed correctly in POL's displaytab.

if i leave the "/0" in place, it shows only "default" for every entry.

 

Edited by loggod

petch Monday 23 March 2015 at 0:43
petch
Developer

I added the wxPython question a bit late, can you try the command mentionned above too?

 

loggod Monday 23 March 2015 at 0:51
loggodAnonymous

ehm i get a

SyntaxError: invalid syntax


if i exceute that python command. is there a typo in it?

 

at the moment i only have wxpython 3.0.2.0-1 installed. should i try to install version 2.8?

edit: btw, i am using manjaro linux xfce 64 bit at the moment :-)

Edited by loggod

petch Monday 23 March 2015 at 0:59
petch
Developer

Alright 3.0.2.0, that's what I wanted to know. You didn't answer about the distro and release though.

I opened a bug report, because that's maybe the third time this problem is mentionned, in the forum or elsewhere: https://www.playonlinux.com/en/issue-5023.html

loggod Monday 23 March 2015 at 1:04
loggodAnonymous

ok thank you for your effort smileyyes

For now i can work around this by editing the corresponding sections in the user.reg per hand. so its not that critical.wink

 

Thank you

loggod

petch Monday 23 March 2015 at 1:17
petch
Developer

From the package version I assume you're running Arch or some derivate distro.

Switching to wxPython 2.8.x could be interesting, if it can be done...

petch Monday 23 March 2015 at 7:50
petch
Developer

Ok, it seems to be some bug in recent Wine versions, at least since 1.7.30, see the bug report. We'll have to decide how to deal with the situation...

And thank you slackner for the info, I was heading in a totally different direction!

Maxi-Waxi Monday 23 March 2015 at 11:39
Maxi-Waxi

I'm not sure if Mint and Ubuntu acts the same way, but adding wine:i386 package as instructed on the Download page fixed the conf issue for me on Ubuntu 14.10.

loggod Monday 23 March 2015 at 12:08
loggodAnonymous

@petch: I am running Manjaro Linux, which is an Arch based Distro, thats right.

Installed wine is multilib. My installed wine version is a 64-Bit Version.

I thought i am using POL to be able to simple create 32-Bit Wineprefixes to run my games in?

 

greetz

 loggod

petch Monday 23 March 2015 at 13:25
petch
Developer

I pushed a workaround in the development version, but it's only slightly tested since I didn't experience the bug in the first place (just checked by adding \0s in the user.reg)