The forum

how to configure printers

replacing old ones

Author Replies
frenkiel Thursday 7 May 2015 at 18:37
frenkielAnonymous

OS: Debian Jessie

POL version: 4.2.7

My new printers are configured with cups, and work perfectly with all Linux applications,

but the POL apps still have the old printers, and I can't find how to forece POL

to use the cups new printers.

I tried to find something with gooogle, without success...

Ronin DUSETTE Friday 8 May 2015 at 18:21
Ronin DUSETTE
Admin

It should just do it. POL/Wine cannot utilize USB drivers, though it should still present itself to the Wine apps as available. Do you have the 32-bit cups libraries? I have actually never tried to do that through Wine. Perhaps you can configure them as network printers instead (unless you already have them that way).

Also, a quick google search popped up a lot of results, one of them being:

http://wiki.winehq.org/Printing

Hopefully this helps find your some more information. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
frenkiel Friday 8 May 2015 at 18:37
frenkielAnonymous

thank you for your reply, but it doesn't help too much:

My 2 old printers were both network printers, on my local ethernet nerwork, and worked perfectly

with POL apps (word,...) without any special configuration. Now,  I have 2 new networks printers,

and POL still sees the old ones.

Ronin DUSETTE Friday 8 May 2015 at 18:53
Ronin DUSETTE
Admin

It is not POL that is causing it; POL is simply a front-end for Wine. What have done to try and figure it out? Have you reinstalled the cups libs, making sure that the 32-bit ones are installed? Have you tried adding the new network printers, not just waiting for them to show up? 

So, you just hooked up the new printers, but attempted no configuration? Or did you add them like any other printer into your list of printers? When you say "no special configuration", did you mean beyond setting them up like a normal printer? Or did you just plug them in and it worked? What type of printers? Now you mentioned that they were networked printers but you didn't tell me that before, so did you add those networked printers into your Linux distro and then they just popped up? Did you have to download any drivers for them? Install any software? POL (really, Wine) sees the old ones; did you delete the old ones and try to scan for new printers?

I am sorry if my previous response didn't help, but you aren't giving me too much info to work with. haha. ;)

Edited by RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Friday 8 May 2015 at 19:06
Ronin DUSETTE
Admin

Here are some more links that I found from google searching:

https://www.winehq.org/docs/wineusr-guide/misc-things-to-configure

https://forum.winehq.org/viewtopic.php?t=677

http://smallbusiness.chron.com/use-printer-through-wine-56744.html

http://wine-wiki.org/index.php/General_Wine_Troubleshooting#Printing

I am going to do more research and try to get more information into our Wiki, but some of those links may help, as well. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
frenkiel Saturday 9 May 2015 at 9:09
frenkielAnonymous

Did you really read my 1st post? It said:

    My new printers are configured with cups, and work perfectly with all Linux applications,
    but the POL apps still have the old printers, and I can't find how to force POL
    to use the cups new printers.

I think that it is clear  enough, isn't it?
I alread read the links you give, and they provide no information about my problem,
as they only claim that there is nothing to do, once cups is properly configured.

    Wine can interact directly with the local CUPS printing system to find
    the printers available on your system. Configuring printers with Wine is
    as simple as making sure your CUPS configuration works.

    You install printers through CUPS, not wine. If it's properly installed
    in CUPS, your wine programs should just see the printer.

as for the last link
    http://wiki.playonlinux.com/index.php/Main_Page
you have a good sense of humor, as it says:

      Using Printers with PlayOnLinux
      Coming soon...

The fact that it's wine and not POL the culprit is secondary, apart that
I should post to a wine forum to have a chance to get a useful answer.

 

frenkiel Saturday 9 May 2015 at 14:57
frenkielAnonymous

In the absence of any useful hint, I found a drastic way to fix the issue: re-installing POL

Ronin DUSETTE Saturday 9 May 2015 at 16:50
Ronin DUSETTE
Admin

 

Did you really read my 1st post? It said:

    My new printers are configured with cups, and work perfectly with all Linux applications,
    but the POL apps still have the old printers, and I can't find how to force POL
    to use the cups new printers.

I think that it is clear  enough, isn't it?
I alread read the links you give, and they provide no information about my problem,
as they only claim that there is nothing to do, once cups is properly configured.

    Wine can interact directly with the local CUPS printing system to find
    the printers available on your system. Configuring printers with Wine is
    as simple as making sure your CUPS configuration works.

    You install printers through CUPS, not wine. If it's properly installed
    in CUPS, your wine programs should just see the printer.

as for the last link
    http://wiki.playonlinux.com/index.php/Main_Page
you have a good sense of humor, as it says:

      Using Printers with PlayOnLinux
      Coming soon...

The fact that it's wine and not POL the culprit is secondary, apart that
I should post to a wine forum to have a chance to get a useful answer.

 

 

Nice attitude. That is the last time that I attempt to help you. lol.  

Oh, and that last link to the wiki that you thought that I was having a sense of humour about; It is in my signature... in every post... as in not part of my actual post... not in the list of links that I gave you...

Edited by RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts