The forum

Accu Chek Smartpix - USB peripheral unstable

Diabetesprogram installs fine as a manual install - but the USB peripheral needed to receive data from devices, connects and disconnects from the computer once you try to use it

Author Replies
Lawsomemrb Tuesday 14 July 2015 at 17:46
LawsomemrbAnonymous

Hey everyone, 
Im fairly new to PlayonMac so please excuse me, if i'm a bit slow. 

I tried to install a certain diabetes program which is only made for windows. To my great amazement, things seem to go quite well and within minutes the program was up and running. Furthermore, once i connected the infrared usb-peripheral used to scan bloodsugar devices, it actually registrered it correctly! 

So far so good - unfortunately once i try to actually use the peripheral. both by actually getting it to scan a device or trying to update the software on the peripheral (there was a update from the manufacturer) - it will appear to function for a couple of seconds and then suddenly an error pops up and Finder tells me that the peripheral has been ejected incorrectly. Shortly after it seems to reconnect and attempt it once again - but continues failing and ejecting. 

The problem does not appear when the peripheral is just connected and doing nothing - which leads me to think that it might have something to do with a port being closed or someting of the like. Does anybody have any idea what might help the issue? During the installation, I didn't choose any custom options or anything of the like - i just clicked on through the manual install. 

I hope somebody can help, since i know quite a bit of diabetics who are in need of the software and could really use a fix such as playonmac! Thank you all in advance. :) 

Edited by Lawsomemrb

Ronin DUSETTE Wednesday 15 July 2015 at 18:04
Ronin DUSETTE
Admin

Unfortunately because of how Wine works (and therefor, POL and POM), it does not support USB drivers, so unless it works native in Linux (or in your case, OSX), Wine will not be able to use it correctly or at all. You will need to see if it is actually recognized and working through OSX before Wine can make any use of it. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts