The forum

Wine/POL - Connection Issues

Why Hearthstone won't work on my system

Author Replies
Novare Thursday 27 August 2015 at 0:02


I'm currently trying to install Hearthstone on my Ubuntu 15.05 (64bit) rig using PlayOnLinux but always experience connection issues with the, which is required to play for some reason. Once I try to login I get sent in a queue which states that I have to wait (probably) less than a minute since "seems to be pretty busy right now". After that, the Launcher says that the connection failed ("Additional help": BLZBNTBGS8000000E (14000)) and offers me to continue in offline-mode (which won't help much, since I need to be connected to play Hearthstone).


This error occurred on every setup I tried to make this thing working on. First, I tried the script provided by PlayOnLinux, since that didn't work I tried to install Hearthstone without that and once that failed I tried to just install the client (all via POL) - all of those attempts led to the same problem.


There are a few fixes for this very issue and general issues with POL and Hearthstone online, none of them worked for me (e.g. the "dbghelp (Disabled) and msvcrp (Native, Builtin)"-Fix, installing wininet and adding it to the DLL-list, adding to the list etc.). I also tried using different versions of Wine, but that didn't solve the problem either (versions I tried: 1.7.15 (recommended by the Hearthstone-POL-installation-script), 1.7.46, 1.7.49 and 1.7.50. I should probably also add that the are in fact up, so there has to be a problem with my setup. The servers I'm trying to connect to are the European ones, my Hearthstone/ installation is set to be in German, therefore I can't really provide any screenshots showcasing the output of the Battlenet-Client and have to stick with describing the issue.


I fully understand that the installation-script is currently in the beta-stage, but this has to be solvable somehow since there's a lot of people successfully running Hearthstone on Ubuntu. Any help related to this issue is greatly appreciated, keep up the good work!

Novare Saturday 29 August 2015 at 18:03

Update: Yesterday I switched back to Windows 8.1 and installed the native version of Hearthstone and, surprisingly, got the same error message. I think it's pretty safe to say that this isn't a problem with POL, but with Hearthstone/ itself, since a lot of forum posts in the official Hearthstone forum report the same issue. I'll mark this as solved, since it's not a POL related issue, apparantly.