The forum

Creating a Launcher for WOW

Trying to add a shortcut to WOW to SteamOS

Author Replies
Jbbrack03 Wednesday 6 July 2016 at 20:50

Hi all,

This is my first experience working with POL. I have a computer running SteamOS (built on Debian Jessie). I setup POL in Desktop mode and used it to install on a 64-bit virtual drive. This worked fine and I was able to log into and install World of Warcraft. I created a Shortcut to WOW from within POL and I can run WOW without any problems from this shortcut. 

My goal is to be able to launch WOW from within SteamOS's Big Picture Mode (the main interface). I can't just add the POL WOW Shortcut to it (when I tried, it would just launch POL with no option to play WOW). After researching a bit, it looks like I need to create a Launcher for WOW to add to SteamOS's Big Picture Mode. I've been trying to do this, but I haven't had any luck in getting it to launch. I created a Bash Script using the Launch Commands from the WOW POL shortcut. I made the script executable and then created a .desktop launcher file to launch the script. It does work in Desktop Mode and launches WOW. I can add this launcher to SteamOS BPM, but when I try to execute it it just loads for a few seconds and then returns to the game page. It never actually opens WOW.

I realize that this is a bit of a crossover between SteamOS and POL. I've posted in the SteamOS boards but haven't received any help so far. I figured I'd post here as well in case anyone has any experience with this sort of thing.

Here's the bash script that I'm using:

/usr/share/playonlinux/playonlinux --run "World of Warcraft" %F

And here's the Launcher:

[Desktop Entry]
Name=World of Warcraft
GenericName=World of Warcraft
Comment=World of Warcraft manual Launcher


I appreciate any advice! Thank you