The forum

cannot even get to install in league of legends

Author Replies
universalturtle Monday 29 August 2016 at 3:34

After finding league of legends in the list of games I click install and it gets stuck on a load screen before the install client can even start. I've run it with terminal and recieved these error messages

/home/USER/.PlayOnLinux//install: line 132: unexpected EOF while looking for matching `''
/home/USER/.PlayOnLinux//install: line 147: syntax error: unexpected end of file

Running Ubuntu 14.04

Help would be greatly appreciated


Edited by universalturtle

4rkz Monday 29 August 2016 at 23:19

I have the same error on 16.04 

4rkz Monday 29 August 2016 at 23:33

Of course the error is in line55.

Just remove the  '  in "doesn't", then go to /home/USER/.PlayOnLinux//install and change permission to read only.

Or just paste the below fixed script into the install file

# Date : (2012-04-12)
# Last revision : (2015-05-31 08:27)
# Distribution used to test : ArchLinux, Debian Sid
# Author : Quentin PÂRIS, Valentin PERRUSSEL, Pierre ETCHEMAITE
# Licence : GPLv3
# WineHQ:

# Changelog
# (2012-05-11) 22:50 - Quentin PÂRIS
#        - New wine patches for better perfomances
# (2012-05-11) 23:38 - Quentin PÂRIS
#        - Dirty hack that fixes problems
# (2012-05-12) 09:45 - Quentin PÂRIS
#        - Patches for osx
# (2012-05-28) 11:00 - Quentin PÂRIS
#        - Checks for recent version of PoL (InsertBeforeWine is bad supported by 4.0.14)
# (2013-03-10) 22:51 - Pierre ETCHEMAITE
#       - Use web downloader
# (2013-04-07) 22:23 - Pierre ETCHEMAITE
#       - Reverted as they somehow broke PMB (not even installed)
# (2013-04-13) 20:12 - GNU_Raziel
#       - Added POL_Wine_SetVideoDriver function
# (2013-09-07) 21:17 - Pierre ETCHEMAITE
#       - Fix for newer LoL versions
# (2014-09-01) 21:17 - Quentin PÂRIS
#       - Fix for newer LoL versions (added d3dx9)
# (2015-01-09) 00:54 - Pierre ETCHEMAITE
#       - Update Wine to fix missing libgcrypto symlink
# (2015-02-10) 20:25 = Pierre ETCHEMAITE
#       - Use official standalone installer/patcher
# (2015-05-31) 08:27 = Pierre ETCHEMAITE
#       - use Wine 1.7.44-LeagueOfLegends2 to fix patcher issue
# (2016-01-26) 12:55 (UTC) - Jeddunk
#       - upgrade Wine to 1.9.2-LeagueOfLegends5

[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"


TITLE="League of Legends"
SHORTCUT_NAME="League of Legends"

POL_GetSetupImages "$PREFIX/top.jpg" "$PREFIX/left.jpg" "$TITLE"

POL_RequiredVersion "4.0.18" || POL_Debug_Fatal "$APPLICATION_TITLE 4.0.18 is required to install $TITLE"
POL_SetupWindow_SetID 1135

which glxinfo || POL_Debug_Error "$(eval_gettext 'glxinfo is not installed. Please install mesa-utils package')"

if ! glxinfo | grep -q GL_EXT_texture_compression_s3tc; then
    POL_SetupWindow_message "$(eval_gettext 'Warning! S3TC compression is not available on your system.\n\nIf you have a free driver, you might need to install a proprietary driver \n\nOtherwise, you can enable it by installing libtxc-dxtn0 package or libtxc-dxtn-s2tc0,libtxc-dxtn-s2tc-bin if the first doesnt work, but you might get slower results')"
    POL_Debug_Warning "S3TC not enabled!"


POL_SetupWindow_presentation "League of Legends" "Riot" "" "Quentin PÂRIS, BlondVador" "LeagueOfLegends"

POL_SetupWindow_InstallMethod "DOWNLOAD,LOCAL"

if [ "$INSTALL_METHOD" = "LOCAL" ]; then
    cd "$HOME"
    POL_SetupWindow_browse "$(eval_gettext 'Please select the setup file to run.')" "$TITLE" "" "Windows Executables (*.exe)|*.exe;*.EXE"

    if strings "$APP_ANSWER"|grep -q '\(name="Pando Media Booster Downloader"\|Advanced Installer\)'; then
        POL_Debug_Fatal "$(eval_gettext 'Cant install using the official downloader, sorry')"
    POL_System_TmpCreate "$PREFIX"

    POL_SetupWindow_menu "$(eval_gettext 'Select installer to download:')" "$TITLE" "$(eval_gettext 'North America')~$(eval_gettext 'Europe West')~$(eval_gettext 'Europe Nordic and East')" "~"
    case "$APP_ANSWER" in
        "$(eval_gettext 'North America')")
        "$(eval_gettext 'Europe West')")
        "$(eval_gettext 'Europe Nordic and East')")
    DOWNLOAD_FILE="$POL_System_TmpDir/$(basename "$DOWNLOAD_URL")"

    POL_Call POL_Download_retry "$DOWNLOAD_URL" "$DOWNLOAD_FILE" "$DOWNLOAD_MD5" "$TITLE standalone installer"


POL_System_SetArch "x86"
POL_Wine_SelectPrefix "$PREFIX"
POL_Wine_PrefixCreate "$WINEVERSION"

POL_Call POL_Install_corefonts
POL_Call POL_Install_vcrun2005
POL_Call POL_Install_vcrun2008
POL_Call POL_Install_d3dx9

Set_OS "win7"

POL_SetupWindow_message "$(eval_gettext 'Warning: You must not tick the checkbox "Run $TITLE" when setup is done')" "$TITLE"

POL_Wine_WaitBefore "$TITLE"

Set_OS winxp

# Set Graphic Card informations keys for wine

POL_Call POL_Function_OverrideDLL builtin,native dnsapi
POL_Shortcut "lol.launcher.admin.exe" "$SHORTCUT_NAME" "$SHORTCUT_NAME.png" "" "Game;RolePlaying;"

if [ "$INSTALL_METHOD" = "DOWNLOAD" ]; then
    # Free some disk space

if [ "$POL_OS" = "Linux" ]; then
    if [ "$(cat /proc/sys/net/ipv4/tcp_timestamps)" = "1" ]; then
        POL_SetupWindow_question "$(eval_gettext 'If you get connection errors when attempting to login, try disabling tcp_timestamps in the kernel.')\n$(eval_gettext 'Do you want to read original thread in League of Legends forums?')" "$TITLE"
        [ "$APP_ANSWER" = "TRUE" ] && POL_Browser "${FORUM_URL}"

exit 0

Version: GnuPG v1


Then run LeagueOfLegends installation thru POL as normal.

You will be prompted in terminal to overwrite the current install file, type "n" and press enter.

Then you will be notified that you're running an unofficial script. Accept it and proceed...


universalturtle Tuesday 30 August 2016 at 8:25

It worked!! thankyou so much!!

baile332 Tuesday 30 August 2016 at 9:18

1. The script doesnt work for me

Error in POL_System_wget
POL_System_wget failed: Server issued an error response
--2016-08-30 00:16:29-- ( to (||:80... connected.HTTP request sent, awaiting response... 403 Forbidden2016-08-30 00:16:29 ERROR 403: Forbidden.


2. And if i choose: use a setup file in my computer:

Error in main
Cant install using the official downloader, sorry


3. I dont find this folder:

Just remove the  '  in "doesn't", then go to /home/USER/.PlayOnLinux//install and change permission to read only.


Thx for help



4rkz Wednesday 31 August 2016 at 0:12

1. Try choosing Europe West server

2. Where do you choose that? 

3. Make sure to replace USER with your valid username


Maybe this instruction will be cleaner:

1. Open terminal (CTRL+SHIFT+T)

2. Type playonlinux 

3. Press ENTER

4. A new window should appear. With mouse press +Install 

5. In the popup window's search bar type League of Legends

6. Select it with mouse and click install.


What happens then?

{ego} Wednesday 31 August 2016 at 3:00

Paste the following into your /etc/hosts file using nano:


This did the trick for me and allowed the installation script  to download the game. I still couldn't launch it after installation though.

zyrro Monday 13 March 2017 at 14:52


Paste the following into your /etc/hosts file using nano:


This did the trick for me and allowed the installation script  to download the game. I still couldn't launch it after installation though.


itahn Sunday 23 April 2017 at 12:21

What I did was this:

Step one: 
Open terminal and enter the next command on the terminal
sudo -i gedit /etc/hosts

Then enter what {ego} said

It has worked for me... thanks man!! I really apreciate it... 

Also I followed this guides :

And made some extra modifications to the host file to avoid some malware and obnoxious ads on my chromiun and chrome browsers 

My specs are these: 
Memory RAM:  32 GiB
Processor:   AMD® Fx(tm)-8350 eight-core processor × 8
Graphics:    AMD® Polaris10 , VisionTek Radeon RX 470
Base System: Ubuntu Budgie Release 17.04 64-bit