The forum

Problem installing LoL in Playonlinux

League of Legends

Author Replies
jameslredfield Friday 9 September 2016 at 17:33

I recently started running Ubuntu 16.04 and I'm new in this OS. I installed POL (v4.2.10) and have an ASUS k550C, i7 core, 8GB DDR3 RAM, 1GB NVIDIA of media (not very much but usefull).

I tried to install League of Legends, and the program asked me for mesa-utils package. I installed it using sudo apt-get install mesa-utils as I thought it would solve the problem, but now when I try to install LoL, PoL crashes and keeps loading and loading without doing anything. I've tried to wait 5 or 10 minutes so far, and don't think it would stop.

I would like to send a picture to show but I can't find it, and I think is pretty simple, the program just doesn't load at that point.

P.S: Sorry about my english.

Thanks to whoever can help.

EDIT: Now I don't have this problem following chodi's post in this thread

But the instalation stops when tahoma is installing.

Edited by jameslredfield

weyderfs Tuesday 27 September 2016 at 3:59

I got it to install, but had the following errors:

err:module:import_dll Library DNSAPI.dll (which is needed by L"C:\\Riot Games\\League of Legends\\RADS\\projects\\lol_patcher\\releases\\\\deploy\\LoLPatcher.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Riot Games\\League of Legends\\RADS\\projects\\lol_patcher\\releases\\\\deploy\\LoLPatcher.exe" failed, status c0000135
fixme:advapi:EventUnregister deadbeef: stub
fixme:advapi:EventUnregister deadbeef: stub
fixme:advapi:EventUnregister deadbeef: stub
fixme:advapi:EventUnregister deadbeef: stu


I use KDE Neon 5.7.5

Edited by weyderfs

weyderfs Tuesday 27 September 2016 at 13:24

Hi heveryone,

I got it!!!!! laugh

I uninstalled and reinstalled again, but in the end of instalation I removed the checkbox option "start laucher of league of legends". IMPORTANT not run the game before of the next steps:

After change version of the Wine to 1.9.2-staging-LOL3 and the last tab "Miscellaneous" in the fist option "replace leak mouse"  select ENABLE.

Link game running: