The forum

Cant install Diablo 3 after Rise of Necromancer update

Author Replies
prvst Wednesday 28 June 2017 at 0:33


I was playing Diablo 3 normally with the install from the Diablo 3 entry on the pplication list. Today , after buying the expansion I opened the app and instead of seeing the default screen with the small options on top and the Install / Play button on the bottom, I can only see an empty screen (with the backgroud image of the necro) and two small squares that looks like empty buttons on the top left corner. 

I tried deleting evrything to reinstall but the same thing happen afeter installing the (via Diablo 3 recipe).


Any suggestions on how to fix this ?

isophotek Thursday 29 June 2017 at 18:52



I have the exact same problem as you described. D3 worked before the Necro update. I also tried to reinstall but had no luck.


Would be grateful if someone found a solution.

isophotek Thursday 29 June 2017 at 19:05

There is actually a fresh update for that, not approved yet but worked for me. I get content in the blizzard app, and I am currently installing D3 itself