The forum

Installation Error on CentOS 7.7

Author Replies
anselmo Monday 23 September 2019 at 6:26
anselmoAnonymous

CentOS 7.7 has been released recently.

When installing PlayOnLinux in CentOS 7.7 thru yum, or when updating CentOS from 7.6 to 7.7 thru yum with installed PlayOnLinux, libSPIRV-Tools.so and libSPIRV-Tools-opt.so are conflicted.


=====================================================================================================================================
 Package                             Arch                      Version                          Repository                      Size
=====================================================================================================================================
Installing:
 playonlinux                         noarch                    4.3.4-fedora0                    playonlinux                    3.0 M
Installing for dependencies:
 libvkd3d                            x86_64                    1.1-2.el7                        epel                           152 k
 spirv-tools-libs                    x86_64                    2019.1-1.el7                     epel                           994 k
 wine                                x86_64                    4.0-2.el7                        epel                            50 k
 wine-alsa                           x86_64                    4.0-2.el7                        epel                           104 k
 wine-capi                           x86_64                    4.0-2.el7                        epel                            57 k
 wine-cms                            x86_64                    4.0-2.el7                        epel                            75 k
 wine-common                         noarch                    4.0-2.el7                        epel                           104 k
 wine-core                           x86_64                    4.0-2.el7                        epel                            28 M
 wine-desktop                        noarch                    4.0-2.el7                        epel                           153 k
 wine-ldap                           x86_64                    4.0-2.el7                        epel                           128 k
 wine-openal                         x86_64                    4.0-2.el7                        epel                            64 k
 wine-pulseaudio                     x86_64                    4.0-2.el7                        epel                            91 k
 wine-twain                          x86_64                    4.0-2.el7                        epel                            85 k

Transaction Summary
=====================================================================================================================================
Install  1 Package (+13 Dependent packages)

Total size: 33 M
Installed size: 224 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/lib64/libSPIRV-Tools-opt.so from install of spirv-tools-libs-2019.1-1.el7.x86_64 conflicts with file from package vulkan-1.1.97.0-1.el7.x86_64
  file /usr/lib64/libSPIRV-Tools.so from install of spirv-tools-libs-2019.1-1.el7.x86_64 conflicts with file from package vulkan-1.1.97.0-1.el7.x86_64

Error Summary
-------------


So I can't use PlayOnLinux on CentOS 7.7.

As https://bugzilla.redhat.com/show_bug.cgi?id=1745104, it seems CentOS bug, but it may not fixed sooner or later.

How can I use PlayOnLinux?

Please help me.

Edited by anselmo

Dadu042 Monday 23 September 2019 at 16:56
Dadu042
Moderator

Sorry I don't know how to help, and it seems to me that POL v4. not receive any updates, because the devs are working on POL v5 (still in alpha version state).