The forum

ADE Requirements?

Getting ADE to work

Author Replies
Beaverbuddy Friday 3 April 2020 at 1:44
BeaverbuddyAnonymous

I've tried to install several versions of Adobe Digital Editions, and none have worked.  I have seen people post that it's installed with no problems.  Am I missing some requirement that is obvious to experts?  Does netbind have to be installed first?  Some other program or library?  Does it only work if you have exactly the right versions of Wine, ADE, and whatever other bits are necesary?

 

The errors I've been getting seem to involve Presentation Framework.

Dadu042 Friday 3 April 2020 at 11:10
Dadu042
Moderator

"Am I missing some requirement that is obvious to experts? " (Presentation Framework.)   I think so : dotnet.

Beaverbuddy Friday 3 April 2020 at 23:48
BeaverbuddyAnonymous

I assumed that the appropriate version of dotnet was installed by the ADE installer, as was said in a different post about how it's done.  I think dotnet 4.0 is installed, though I'm not sure what specific version of dotnet (and Wine) is required for a specific version of ADE.  I don't know of a simple way to remove one version of dotnet and replace it with another.  I can try building different prefixes with different versions of dotnet.  I was wondering if anyone had actually figured out the secret for getting ADE to run under linux.  I thought maybe there was some tool or other software that the successful people installed immediately every time they installed a new version of linux, which set up something required by ADE.

Beaverbuddy Saturday 4 April 2020 at 18:38
BeaverbuddyAnonymous

I managed to finally get ADE 4.0 running, without using POL.   I followed instructions from forum.mxlinux.org/viewtopic.php?t=46640 , installing ADE 4.5, then installed 4.0 into that same prefix, and it ran properly.  I'd tried installing 4.0 by itself, without success, but doing it in this order worked.  Maybe the stars were in alignment and the moon was in the correct phase.  BTW, previous attempts did in fact have dotnet and netbind installed; not sure which versions are in the working setup.

Dadu042 Sunday 5 April 2020 at 10:41
Dadu042
Moderator

paavola Tuesday 28 April 2020 at 18:59
paavolaAnonymous

ADE also does not work for me. Installation goes without any error messages but when I run the program, I get an error:

CLR error: 80004005
The program will now terminate.

This seems to be something to do with the .Net support. I have tried pretty much every combination of Wine and dotnet or wine-mono that is available to no avail. I was hoping that POL would have the magic combination. Anyone have any suggestions?
 

Dadu042 Tuesday 28 April 2020 at 22:10
Dadu042
Moderator

I had this error message with other softwares after installing dotnet40, usually installing dotnet461 does fix the issue.