The forum

Oblivion installed but doesn't work

Author Replies
d107 Monday 4 May 2020 at 1:33

Hello. I have Oblivion installed in POL successfully, but when launching, it doesn't seem to be detecting keyboard or mouse input. I get Bethesda's splash pages including the "2K Games" logo and others. I get the usual music. But I should be able to ESC out of this to begin. There's no input response. Once the intro has finished, it stays at a black background with just the music playing. If I ALT+TAB out, I see that Wine has crashed.

I had previously set it up in Lutris and had the same experience. Then after installing in POL, there were some .NET patches needing applied as well as "wine-mono" package and "Gecko". Those installed but the problem continues.

If there's a logfile or troubleshooting switches that could help, I can do that. Any suggestions are appreciated.

d107 Tuesday 5 May 2020 at 1:23

Update: Fixed, kinda. The Oblivion.log file in the POL logs folder is about half the following two errors spammed hundreds of times:
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x153950, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_REF, src_format WINED3DFMT_B5G6R5_UNORM, dst_format WINED3DFMT_B8G8R8X8_UNORM stub!

fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
I found similar threads on other games which suggested lowering the POL Display option for "Video memory size" to 3072. Amazingly that seems to have fixed it.

That of course limits my graphics ability. On a 14 year old game its not a huge deal, though I expect to see this again, and I like to max display options. It seems this isn't an uncommon problem.

Ubuntu 18.04 LTS
Video Card: GeForce GTX 1660 Ti, 6GB
POL 4.2.12
Wine 3.0

d107 Wednesday 17 June 2020 at 1:05

Is there really no one else interested in Oblivion? Am I showing my age? There are many "legacy" games and apps supported by POL.

After making the above change, it worked fine for 6 weeks; about 50-100 game launches. It would occasionally crash after which I could reboot and it would work.

Then the same problem started even with the Video Memory Size reduced to 3072. Even rebooting and starting clean, it crashes.

I dropped it again to 2048, and its working yet again. I think I'm backing myself into a corner here having to keep dropping it (and deal with lesser graphics abilities). There appears to be a video memory leak or some sort of other issue.

Dadu042 Wednesday 17 June 2020 at 8:13

Perhaps newer Wine versions may help.

POL 4.2.12 only allows using Wine up to v3.20 (~ 2016).