The forum

Wine 5.18: Can't install vcrun2010 (crash)

Linux Mint 19.3, POL 4.3.4, AMD A10-5800K, R9 Nano, 8gb ram

Author Replies
data-angel Wednesday 14 October 2020 at 3:46

I'm not sure what to do, could someone explain what this means? I'm trying to install it on a 32bit prefix and i get this error: 

Unhandled exception: C++ exception(object = 0x0031f594, type = 0x1009c200) in 32-bit code (0x7b00f814).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:7b00f814 ESP:0031f4a4 EBP:0031f508 EFLAGS:00000246(   - --  I  Z- -P- )
 EAX:0031f4b0 EBX:0031f594 ECX:00000008 EDX:0031f534
 ESI:100187ac EDI:00000000
Stack dump:
0x0031f4a4:  00110094 00000000 100858ab e06d7363
0x0031f4b4:  00000001 00000000 7b00f814 00000003
0x0031f4c4:  19930520 0031f594 1009c200 7bc268ae
0x0031f4d4:  00110094 100858ab 00110000 00000000
0x0031f4e4:  001ad878 0031f514 0031f514 1005ed93
0x0031f4f4:  1005ed98 59454131 00110094 00000000
=>0 0x7b00f814 RaiseException+0x6f(code=<is not available>, flags=<is not available>, count=<is not available>, args=<is not available>) [Z:\root\wine-git\dlls\kernelbase\debug.c:316] in kernelbase (0x0031f508)
  1 0x1008188f in setupengine (+0x8188e) (0x0031f540)
  2 0x10066e96 EntryPoint+0xffffffff() in setupengine (0x0031f5b0)
  3 0x1006380b EntryPoint+0xffffffff() in setupengine (0x0031f5d0)
  4 0x10061405 EntryPoint+0xffffffff() in setupengine (0x0031f608)
  5 0x10035a52 EntryPoint+0xffffffff() in setupengine (0x0031f678)
  6 0x1006b83a EntryPoint+0xffffffff() in setupengine (0x0031fdd8)
  7 0x1005faa0 EntryPoint+0xffffffff() in setupengine (0x0031fe48)
  8 0x100580de EntryPoint+0xffffffff() in setupengine (0x0031fe9c)
  9 0x00402928 EntryPoint+0xffffffff() in setup (0x0031ff30)
  10 0x7b65f260 in kernel32 (+0x3f25f) (0x0031ff48)
  11 0x7bc57307 RtlSleepConditionVariableSRW+0x156(variable=<is not available>, lock=<is not available>, timeout=<is not available>, flags=<is not available>) [Z:\root\wine-git\dlls\ntdll\sync.c:556] in ntdll (0x0031ff5c)
  12 0x7bc574f8 call_thread_func+0xb7() [Z:\root\wine-git\dlls\ntdll\thread.c:133] in ntdll (0x0031ffec)
0x7b00f814 RaiseException+0x6f [Z:\root\wine-git\dlls\kernelbase\debug.c:316] in kernelbase: movl 0xfffffffc(%ebp),%ebx
Unable to access file 'Z:\root\wine-git\dlls\kernelbase\debug.c'
Module Address Debug info Name (48 modules)
PE   320000-  344000 Deferred        sqmapi
PE   400000-  415000 Export          setup
PE   420000-  895000 Deferred        msi
PE 10000000-100c8000 Export          setupengine
PE 61740000-617e6000 Deferred        advapi32
PE 61940000-61a8e000 Deferred        wininet
PE 62e00000-62e2c000 Deferred        odbccp32
PE 62fc0000-6314e000 Deferred        rpcrt4
PE 63480000-63497000 Deferred        version
PE 637c0000-639c6000 Deferred        urlmon
PE 63bc0000-63bf1000 Deferred        shcore
PE 64a40000-64b26000 Deferred        shlwapi
PE 64ec0000-65192000 Deferred        oleaut32
PE 658c0000-658f2000 Deferred        sxs
PE 67840000-6784f000 Deferred        psapi
PE 68080000-680c1000 Deferred        jsproxy
PE 68500000-685fb000 Deferred        combase
PE 68700000-68766000 Deferred        uxtheme
PE 69600000-696c6000 Deferred        winhttp
PE 6a300000-6a31d000 Deferred        userenv
PE 6a400000-6a753000 Deferred        ole32
PE 6aa40000-6aadb000 Deferred        usp10
PE 6bc00000-6bc6f000 Deferred        sechost
PE 6bcc0000-6be09000 Deferred        setupapi
PE 6cc40000-6cf37000 Deferred        comctl32
PE 6d580000-6d5c5000 Deferred        cabinet
PE 6db40000-6db67000 Deferred        imagehlp
PE 6ed00000-6f231000 Deferred        user32
PE 6f4c0000-6f537000 Deferred        wintrust
PE 70940000-70981000 Deferred        mpr
PE 710c0000-710e4000 Deferred        mspatcha
PE 71200000-71232000 Deferred        imm32
PE 7b000000-7b240000 Dwarf           kernelbase
PE 7b620000-7b7dd000 Export          kernel32
PE 7bc00000-7be17000 Dwarf           ntdll
PE 7d430000-7d433000 Deferred        kerberos
PE 7d670000-7d674000 Deferred        winex11
PE 7dbc0000-7dbc4000 Deferred        msvcrt
PE 7dc90000-7dc94000 Deferred        dnsapi
PE 7dcc0000-7dcc4000 Deferred        iphlpapi
PE 7dcf0000-7dcf3000 Deferred        netapi32
PE 7dd40000-7dd43000 Deferred        secur32
PE 7ddc0000-7e697000 Deferred        shell32
PE 7e800000-7e804000 Deferred        ws2_32
PE 7e840000-7e844000 Deferred        bcrypt
PE 7e890000-7e8d4000 Deferred        crypt32
PE 7e9a0000-7e9a7000 Deferred        gdi32
PE 7eb60000-7eb64000 Deferred        ucrtbase
process  tid      prio (all id:s are in hex)
00000038 services.exe
0000003c    0
00000040    0
0000004c    0
00000064    0
000000cc    0
00000044 winedevice.exe
00000048    0
00000054    0
00000058    0
000000a4    0
0000005c plugplay.exe
00000060    0
00000068    0
0000006c    0
00000070    0
000000a8 vcredist_x86.exe
000000ac    0
000000e8    0
000000b0 explorer.exe
000000b4    0
000000b8    0
000000bc    0
000000c4 rpcss.exe
000000c8    0
000000d0    0
000000d4    0
000000d8    0
000000dc    0
000000e0    0
000000e4    0
000000f4    0
000000ec (D) c:\3090a7a2e9e3567692\Setup.exe
000000f0    0 <==
00000100    0
System information:
    Wine build: wine-5.18
    Platform: i386
    Version: Windows XP
    Host system: Linux
    Host version: 5.4.0-48-generic
Dadu042 Wednesday 14 October 2020 at 10:25

Wine is crashing. Are you trying VCRUN2010 from the standarone .EXE file, or from the POL function ? (recommended).

data-angel Wednesday 14 October 2020 at 14:07

from the POL function I think. Configure>install components>vcrun2010.

the wine version i'm using is 5.18

Dadu042 Thursday 15 October 2020 at 10:05

Some of the Wine 5.x latest builds are corrupted, the (only) developper too busy. Try a other Wine version (I have better results with v5.17).

data-angel Thursday 15 October 2020 at 21:05

none of the wine versions i tried seem to work with it? 5.19, 5.17, 3.14, 4.2, 2.4 all have the same issue for me, but 2.4 has worked for someone else