The forum

Error installing components

Author Replies
staticgerbil Wednesday 29 September 2021 at 7:27


I am running Play On Mac 4.4.3 on Big Sur 11.6 and I am unable to use the "Install components" UI to... install components.

I have tried installing many different components including gecko, dotnet, directx, dxvk and all of them give me a message saying

"An error happened during download.
Do you want to retry?"

I have also tried running scripts I have found on this website to install those same components using Tools -> Run a local script without success.

I have also tried using the Play On Mac Console to run commands like...

POL_Download_Resource "" "09058abcd44d72a7555fac0a2254351a"

which results in repeated output like this...

[POL_Download_Resource] Message: Downloading resource
cat: dxvk-1.9.1.tar.gz: No such file or directory
[POL_SetupWindow_question] Message: question answer: False

Manually entering that url into my web browser does get me the file, so the link is valid.

Does anyone have any ideas on solving this one?  For the most part I have been able to manually install components I need by finding appropriate windows installers and just running them with wine in my prefix but I'd love to be able to have the convenience of this Play On Mac UI.

Thanks for any help.

Dadu042 Sunday 3 October 2021 at 17:56

I think it's because of https intead of http frown.


A workaround is to copy the file into the folder 'ressources' (see: ).


Note: this kind of issue should be reported in the function's thread ( ).

Edited by Dadu042

kotosam Saturday 19 March 2022 at 9:32

This method with copying exe file to ressources folder does not seem to work on mac. I'm trying to install dotnet35 and as the link is broken I tried with copying dotnetfx35.exe to /Users/myusername/Library/PlayOnMac/ressources/dotnet35/dotnetfx35.exe and to /Users/myusername/Library/PlayOnMac/ressources/dotnetfx35.exe but it does not work. Did anyone find any method to fix broken links in mac version? Is there any way to edit those broken links somewhere?


It turned out that it actually works at least partially, the problem was that in fact it was trying to download dotnet20 first I found that by checking scripts in /Users/myusername/Library/PlayOnMac/tmp/ directory and it turned out that I can just copy links to those exe files that cannot be downloaded to web browser and download them in web browser and then put to ressources/dotnet20/... So it looks like downloading file in PlayOnMac install components does not work but you can download them manually with links from scripts in tmp folder. However still I have more errors after that which seem impossible to fix.

Edited by kotosam