The forum

Problème avec Guild Wars

lors du lancement

Author Replies
Kenairod Saturday 12 July 2008 at 18:45
KenairodAnonymous

Bonjour, lorsque je double-clique sur l'icône de Guild Wars dans la liste de PlayonLinux il se lance : la fenâtre de chargement s'ouvre, puis la souris apparait et plus rien !
Pouriez-vous m'aider

P.S. : Je suis nouveaux sur PoL (je l'ai télécharger hier soir)

Free the world, take Linux.
ryousuke Saturday 12 July 2008 at 19:16
ryousuke

Il faudrait que tu donnes plus de details. Tu utilises quelle version de Wine avec ?

Va lire ici : http://www.playonmac.com/fr/topic-46-Expliquer_son_problme.html

Sans rien savoir c'est un peu dur de t'aider ^^
Kenairod Saturday 12 July 2008 at 20:47
KenairodAnonymous

Désolé pour le manque d'infos
Alors, j'ai Ubuntu Hardy Heron 8.04, Wine (désolé mais je ne sais pas quelle version, pourrais-tu me dire comment faire stp), GNOME et KDE (mais j'utilise plutot GNOME pour l'instant mais petit à petit je migre vers KDE,), (les erreur sont précisées au topic du dessus ) et par contre je ne comprend pas

- En fonction du type d'erreur, votre configuration.

Quote

Voilà !
bon je sais j'ai presque rien apporté mais je connais pas le reste

Encore désolé pour le manque d'infos.

Free the world, take Linux.
ryousuke Saturday 12 July 2008 at 20:56
ryousuke

Pour la version de Wine, je parlais de celle assigné au jeu par POL. Donc tu ouvres POL et tu cherches un peu parce que j'ai pas linux sous la main ^^ (en fait c'est meme pas mon PC..)
Il semblerait que GW ait quelques problemes avec certaines versions de Wine. Apparement la version 1.0 marche impeccable donc le mieux serait d'assigner celle la directement.
Kenairod Saturday 12 July 2008 at 21:01
KenairodAnonymous

J'ai trouvé du premier coup !
Bon , j'ai la 1.0~rc2

(pourvu qu'ça marche )

Free the world, take Linux.
j_sec Monday 14 July 2008 at 1:04
j_secAnonymous

Personnellement j'ai exactement le même problème sur ma fedora 9. Bizzare ...
Kenairod Monday 14 July 2008 at 13:41
KenairodAnonymous

très énervant

Free the world, take Linux.
j_sec Tuesday 15 July 2008 at 21:21
j_secAnonymous

Alors avec Wine 0.9.43, le jeu ne se lance jamais et ne signale aucune erreur non plus (en mode console). Avec Wine 1.0.0 écran noir tout de suite avec la souris GW. Je ne Peux même pas rentrer le mot de passe. (et comme j'ai un écran noir je ne peux voir s'il affiche des erreurs.). De plus mon pc est completement bloqué avec l'écran noir : obligé de le rebooter

Petites précisions concernant ma config :
- DELL XPS M1530
- Core 2 duo 2.2Ghz
- 3 Go de Ram
- Geforce 8600M GT 258 Mo
- fedora 9 - drivers graphiques kmod-nvidia - je n'utilise pas le bureau 3d.

Quelqu'un à une idée ?
Kenairod Wednesday 16 July 2008 at 13:46
KenairodAnonymous

Moi avec la 1.0.0 c'est pareil, mais j'ai pas essayer les versions antérieurs

Edited by Kenairod


Free the world, take Linux.
j_sec Thursday 17 July 2008 at 10:37
j_secAnonymous

Personne n'a d'idée ? Moi perso je pensais peut être un problème de son ... comment lancer GW en désactivant le son de wine pour vérifier ?
j_sec Monday 21 July 2008 at 23:59
j_secAnonymous

un petit UP ?
Kenairod Sunday 27 July 2008 at 15:02
KenairodAnonymous

Re-up !

Free the world, take Linux.
Aymeric P. Wednesday 30 July 2008 at 0:25
Aymeric P.
Admin

Essayer la combinaison de touche "ALT+ENTRéE" pour basculer plein écran/fenêtré lorsque l'écran est noir à cause de la fenêtre de GW (normalement le son fonctionne).
Essayer aussi de lancer le jeu par la console (playonlinux --run "Guild Wars") avec l'option -windowed => playonlinux --run "Guild Wars" -windowed
Essayer différent réglage de wine
Essayer d'être patient jusqu'à ce que je revienne de vacance pour la suite de la discution :-) (mi août)
Voir aussi le problème décrit sur cette page : http://wiki.winehq.org/PreloaderPageZeroProblem (Attention noté bien ce que vous faite, pour réparer/rétablir au cas où)
--
Astuce pour ne pas rebooter en cas de plantage
Basculer sur les tty (CTRL+ALT+F1), remplir le nom d'utilisateur et mdp du compte utilisant GW, exécuter
killall wine<TAB>
killall -9 wine<TAB>
#*<TAB> correspond a l'appui de la touche TABulation qui permet d'avoir de compléter la ligne automatiquement
éventuellement regarder la liste des processus avec top (k puis le PID du processus pour tuer un processus, q pour quiter)
Enfin (CTRL+ALT+F7) pour revenir sur l'interface graphique

--
Astuce pour rebooter "proprement"
Effectuer la combinaison de touche suivante :
ALT+SYSRQ+S,U,I,B (SYSRQ correspond avec la touche "Impécr" ; Il faut faire attendre 5-10s entre l'appui sur chaque touche (S U I B)

---

Bonne vacance :-) ; profiter du soleil (pas trop les coups de soleil sur les doigts :/ ) :-)

Edited by MulX


Former member.
Kenairod Sunday 12 October 2008 at 11:21
KenairodAnonymous

Voilà ce que j'obtiens en passant par la console :
dorian@gdv-desktop:~$ playonlinux --run "Guild Wars" -windowed
PlayOnLinux v3.0.8

Checking python : [ Ok ]
dorian@gdv-desktop:~$ Mesa 7.0.3-rc2 implementation error: i915_program_error: E xceeded max temporary reg
Please report at bugzilla.freedesktop.org
DRM_I830_CMDBUFFER: -22
dorian@gdv-desktop:~$

Free the world, take Linux.
Kenairod Sunday 12 October 2008 at 12:42
KenairodAnonymous

Et en utilisant la version 0.9.43 de Wine comme conseillé ici Voilà ce que ça m'affiche : dorian@gdv-desktop:~$ playonlinux --run "Guild Wars" -windowed
PlayOnLinux v3.0.8

Checking python : [ Ok ]
preloader: Warning: failed to reserve range 00000000-60000000
preloader: Warning: failed to reserve range 00000000-60000000
Mesa 7.0.3-rc2 implementation error: i915_program_error: Exceeded max temporary reg
Please report at bugzilla.freedesktop.org
DRM_I830_CMDBUFFER: -22
dorian@gdv-desktop:~$

Edited by Kenairod


Free the world, take Linux.
Aymeric P. Monday 13 October 2008 at 19:07
Aymeric P.
Admin

Mesa, i915 !
Tu as une carte graphique Intel ?
Alors ne cherche plus, ce n'est malheureusement pas possible, même si ça fonctionne "bien" sous Windows Vista.

Sinon ça signifie que tu n'as pas les pilotes propriétaire de ta carte d'installer.

Former member.
Panzer Monday 13 October 2008 at 21:21
Panzer

Il me semble que les pilotes Intel sont libres et inclus par défaut dans Ubuntu.

Il y a toujours cette documentation à suivre :
http://doc.ubuntu-fr.org/intel_graphics


Bientot surpuissant ;) http://abe7.labrute.fr
Mon blog (déjà surpuissant) : Le BaB
Aymeric P. Monday 13 October 2008 at 21:30
Aymeric P.
Admin

Oui, je sais les pilotes intel sont libre, seulement j'ai moi même une carte graphique intel 950g, et il est strictement impossible de jouer à guild wars.

Former member.
Kenairod Saturday 18 October 2008 at 13:14
KenairodAnonymous

Snif
Moi qui avais de l'espoir ça casse le moral
Bon et bien tant pis, merci beaucoup !
a +

Free the world, take Linux.