The forum

Serveur X dans la version 1.2

Author Replies
bastien09 Tuesday 5 May 2009 at 22:08
bastien09

Salut à tous,
depuis la version 1.2 de POM je n'arrive plus à lancer aucune application,
il me semble que c'est le serveur Xquartz qui en est la cause.

Voilà ce que dit la console pour l'installation d'ie7 :

Starting quartz-wm
Xquartz: Could not find a new enough X11.app LSFindApplicationForInfo() returned
X11.app = /Applications/Utilities/X11.app
Version = 2.1.5 (2158000), Expected Version > 2.3.0
dyld: warning, DYLD_ setting caused circular dependency in /Applications/PlayOnMac.app/Contents/Resources/playonlinux//bin/X11/X11/lib/libGL.dylib
can't open default display
Running install menu

etc, etc...
ext(self.panel, -1, self.fichier[2].replace("\\\\n","\\n"),pos=(20,80))
IndexError: list index out of range
Traceback (most recent call last):
File "/Applications/PlayOnMac.app/Contents/Resources/lib/guiv3.py", line 443, in AutoReload
self.texte = wx.StaticText(self.panel, -1, self.fichier[2].replace("\\\\n","\\n"),pos=(20,80))
IndexError: list index out of range
dyld: warning, DYLD_ setting caused circular dependency in /Applications/PlayOnMac.app/Contents/Resources/playonlinux//bin/X11/X11/lib/libGL.dylib
dyld: warning, DYLD_ setting caused circular dependency in /Applications/PlayOnMac.app/Contents/Resources/playonlinux//bin/X11/X11/lib/libGL.dylib
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.

Quentin PÂRIS Tuesday 5 May 2009 at 23:07
Quentin PÂRIS
Admin

Arf ... Il faut donc que je corrige ce problème au plus vite
Quentin PÂRIS Tuesday 5 May 2009 at 23:37
Quentin PÂRIS
Admin

Dans quelques minutes, la version 1.2.1

Si ça marche toujours pas il va falloir que je vois ça plus en détail mais ça devrait fonctionner en principe

Sinon, tu pourrais toujours essayer un open /Applications/PlayOnMac.app/Contents/Resources/playonlinux/bin/X11/X11/bin/X11.app (qui renverra une erreur, normal) avant de relancer POM ; mais j'éspère que ce ne sera pas utile

Edited by Tinou

bastien09 Wednesday 6 May 2009 at 11:51
bastien09

Le fichier X11.app n'existe pas :
imac:bin bastien$ open /Applications/PlayOnMac.app/Contents/Resources/playonlinux/bin/X11/X11/bin/X11.app
The file /Applications/PlayOnMac.app/Contents/Resources/playonlinux/bin/X11/X11/bin/X11.app does not exist.

bastien09 Wednesday 6 May 2009 at 15:28
bastien09

OK je viens de tester la version 1.2.1 et tout fonctionne maintenant,
Merci Tinou :D
Et encore bravo pour tout le boulot que tu fait

Edited by bastien09


Quentin PÂRIS Wednesday 6 May 2009 at 18:15
Quentin PÂRIS
Admin

:) De rien

Le site de PlayOnMac va bientôt ouvrir ses portes
super_g2 Wednesday 6 May 2009 at 22:40
super_g2

ohoh playonmac? ^^
sinon, j'avais eu le même souci que bastien, et la dernière version corrige bien le souci, belle réactivité ;)

PlayOn*, c'est top!
Quentin PÂRIS Wednesday 6 May 2009 at 22:52
Quentin PÂRIS
Admin

http://www.playonmac.org ;)