You are here    Forums    PlayOnLinux    Installation CnC3 : wine non détecté? fr

The forum

Installation CnC3 : wine non détecté?

malgré la bonne version...

Author Replies
Kyne Friday 24 August 2007 at 16:27
Kyne Anonymous

Bonjour

J'ai voulu tester d'installer CnC 3 par PlayOnLinux, je vais donc dans Jeux, Command and Conquer 3; Il demande de monter le DvD, je valide, un petit message sur la protection ... ok... il me dit alors qu'il faut la version 0.9.41 de wine (j'ai la 0.9.43) et ... je valide, et paf, retour au menu....

J'ai vérifié que j'avais bien la version 0.9.43, j'ai essayé en installant la 0.9.41 dans le menu expert/WineVersions ... mais ca ne marche toujours pas ..

Ubuntu : Feisty fawn

Un petit coup de main?
yourimacmiloud Tuesday 28 August 2007 at 11:58
yourimacmiloud Anonymous

Bonjour,

J'ai eux le même problème que j'ai pu résoudre avec la méthode suivante.

Tu dois éditer le fichier Command and conquer 3 qui se trouve dans le dossier jeux de POL : ~/.PlayOnLinux/jeux/

Là tu cherches ceci :

WINE_CHK_VERSION=`wine --version`
if [ "$WINE_CHK_VERSION" != "wine-0.9.41" ]; then
     message "$LNG_GIT_CNC3_CHECK"
     exit 0

tu remplaces wine 0.9.41 par ta version, tu enregistres et hop ça marche.

P.S: attention si tu mets à jour la liste des jeux sur internet tu perdras cette modification.
Kyne Tuesday 28 August 2007 at 22:42
Kyne Anonymous

Ok, alors voici une "correction" du script qui marchera pour toute version de wine

#!/bin/bash
WINE_CHK_VERSION=`wine --version | grep '[0-9][0-9]' -o`
if [ "$WINE_CHK_VERSION" < "41" ]; then
     echo "C'est pas bon"
     exit 0
else
     echo "C'est bon, version de wine 0.9."$WINE_CHK_VERSION "détectée"
fi


Evidemment si un jour wine 1.x.x sort, l'écho sera dépassé, mais je l'ai mis pour comprendre lol, inutile de le mettre (surtout qu'on lance pas forcément en console PlayOnLinux)



Par contre maintenant j'ai l'erreur du CD1 qu'il ne trouve pas.... pffff

Edited by Kyne

Kyne Tuesday 28 August 2007 at 22:59
Kyne Anonymous

Ah et j'oubliais, j'ai du monter moi même le DVD ... car Ubuntu n'y arrive pas par défaut

(en root : mount /dev/cdrom /media/cdrom0 si je me rappelle bien)

Edited by Kyne