The forum

(Steam) Pas de son sur Super Meat Boy

Author Replies
Ejis Sunday 2 January 2011 at 21:01
Ejis

Bonjour,

mon premier problème avec Steam semble réglé, donc je vais maintenant attaquer le deuxième.
Le premier jeu que j'ai acheté sur Steam est Super Meat Boy, parce que la promo de Noël valait vraiment l'investissement. Et le jeu est par ailleurs formidable ! La manette est bien détectée et c'est fluide. Je connais des accélérations lors des scénettes, mais c'est un dysfonctionnement connu qui n'a pas été réglé à ce jour, semble-t-il.

Cependant, je rencontre un problème qui ne semble pas avoir été soulevé par WineHQ : il n'y a pas de son.

J'ai téléchargé une démo au hasard pour voir si ça venait des configurations de Wine, mais cette démo me renvoyait du son. J'ai lu que certains jeux téléchargés sur Steam nécessitaient parfois un traîtement particulier sous Wine. Sauriez-vous me guider pour le trouver sur ce jeu ?

Je vous en remercie d'avance.
GNU_Raziel Monday 3 January 2011 at 1:35
GNU_Raziel

Tu réussi a le faire fonctionner, bravo, chez moi il crash au lancement...si je réussi a régler le problème je me pencherais sur le bug du son.
Ejis Monday 3 January 2011 at 13:45
Ejis

J'avais un crash perpétuel à cause de la résolution d'écran si je passais en mode fenêtre avec une résolution trop basse.
Ton problème peut venir de là.

Edited by Ejis

Ejis Tuesday 4 January 2011 at 8:58
Ejis

Voici mon UserData/Reg0.dat.

Peut-être que ton Super Meat Boy se lancera avec celui-là.
Ejis Saturday 15 January 2011 at 15:28
Ejis

Y a-t-il eu des avancées ?
animehq Saturday 15 January 2011 at 16:40
animehqAnonymous

J'essayerai bien de t'aider mais a plus de 13€ a l'heure actuel, je n'ai pas envi de l'acheter.
SuperPlumus Saturday 15 January 2011 at 17:09
SuperPlumusAnonymous
Admin

As-tu déjà essayé l'astuce suivante ?
http://www.playonmac.com/fr/topic-265-Astuce_Corriger_probleme_de_son_Steam.html

Edited by SuperPlumus

Ejis Saturday 15 January 2011 at 18:37
Ejis

As-tu déjà essayé l'astuce suivante ?
http://www.playonmac.com/fr/topic-265-Astuce_Corriger_probleme_de_son_Steam.html

Quote from SuperPlumus


Oui, et ça n'avait pas fonctionné.
animehq Saturday 15 January 2011 at 20:39
animehqAnonymous

Le jeu a bien un son stéréo? wine ne prend pas en charge mieux
Ejis Saturday 15 January 2011 at 21:09
Ejis

Il n'y a aucune raison pour que SMB ait un son en dolby. Je ne peux pas le vérifier, malheureusement, mais ce serait surprenant.
animehq Sunday 16 January 2011 at 0:43
animehqAnonymous

Un pote a acheter le jeu je teste avec son compte steam
animehq Sunday 16 January 2011 at 2:23
animehqAnonymous

Le son fonctionne pour moi, merci pour ton reg0.dat sinon je ne pouvait pas lancer le jeu du tout.
Fonctionne pour moi avec la config suivante : http://data.imagup.com/5/1109811906.jpg

Resultat : http://www.youtube.com/watch?v=e-GIs8VIVr4

Edited by animehq

Ejis Sunday 16 January 2011 at 9:57
Ejis

Fonctionne pour moi avec la config suivante : http://data.imagup.com/5/1109811906.jpg

Quote from animehq


Je suis passé de la version 1.3.9 de Wine à la version 1.3.11 et le son a fonctionné ! Par contre, j'ai pu laisser l'échantillonnage à 44100 sans problème.
Donc apparemment, la version de Wine que j'utilisais était fautive.

Merci beaucoup pour ton aide ! :)

Edited by Ejis

Ejis Sunday 16 January 2011 at 10:07
Ejis

Ah ! c'était trop beau : le son fonctionne au début, mais une fois que j'affiche le menu de l'écran-titre, le son s'arrête. On dirait que ça se coupe quand un effet sonore s'enclenche.
Mais on a progressé…
animehq Sunday 16 January 2011 at 13:04
animehqAnonymous

Ah ! c'était trop beau : le son fonctionne au début, mais une fois que j'affiche le menu de l'écran-titre, le son s'arrête. On dirait que ça se coupe quand un effet sonore s'enclenche.
Mais on a progressé…

Quote from Ejis


Pour moi le son fonctionne toujours, pourtant j'en suis au lv 7.