The forum

Cannot locate CD-ROM on any games

Age of Empires II the Age of Kings

Author Replies
GrantRS Friday 21 October 2011 at 16:32

No matter which game I try to run, the games installs, but cannot find the CD-ROM to play the game. I am using Ubunto 11.10 & PlayOnLinux. Am a new user on Ubunto which is part of the problem. Any help would be appreciated.
GrantRS Friday 21 October 2011 at 16:56

Why is my message marked as Solved????
GrantRS Friday 21 October 2011 at 16:57

Why is my message marked as Solved????
mike2507 Tuesday 1 November 2011 at 16:37

ive got the same problem when trying to play tes morrowind

searching tru older posts , it seems to be a reoccurring problem , but almost all post are unanswerd

machine specs:
ubuntu 11.10
pol 4.0.12
wine: don't know

if you need more info, just ask
thanks for the help

( sorry for the bad english, not my native language)

Edited by mike2507

Martha Saturday 12 November 2011 at 0:32

I am having the same issue. Fable The Lost Chapters cannot find the CD-ROM to even install. The Sims Medieval errors with a critical error while trying to install. Sims2 cannot find the CD-ROM to play the game after install. So far the only game I can use since using Wine is Wizard101. Which plays as well as in windows for me. So, I have one game to play since installing Ubuntu 11.10
Thievingtaffer Tuesday 15 November 2011 at 3:50

I'm having the same issue with Morrowind. PlayOnLinux finds it fine for the install, but when I try to run the game, it says "unable to find a CDROM drive on this computer".

I think that this might be a general Wine issue, and not a PlayOnLinux issue, but I'm not sure, and any help would be appreciated. Thanks.
quade Thursday 14 May 2015 at 4:53

I cannot install sims2 because wine does not recognise the disc is there when prompting for disc2.

quade Thursday 14 May 2015 at 5:06

Does anyone have any way around that? So far I have tried:

wine eject d:

Ronin DUSETTE Thursday 14 May 2015 at 7:33

Necromancy is a no-no (this thread was last updated like, 4 years ago). lol. Please start a new thread next time. For now, you could try to copy the discs to a folder and point the installer there instead of the discs. This is a common workaround for this problem. So, instead of telling it to use a disc, tell it to use an EXE (most of the installers give this choice), and then just point the installer to where you copied the discs to. 

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts