The forum

Diablo 3 : wrong video card detected

Author Replies
pauldijou Wednesday 23 May 2012 at 21:59


First of all, thanks a lot for allowing us to play at this game on Linux.

About my installation, everything was fine. But when I tried to
launch the game by clicking on the "Play" button of the Diablo 3
launcher, I got the following error message :

We have detected that your video card is not supported by Diablo III.

Operating System: Windows 7 Service Pack 1

Video Card: NVIDIA GeForce3

And then it redirects me to

The problem is that, in reality, I have a Radeon HD 5700... I guess
there is a way to configure the video card in Wine but since I'm new to
both POL and Wine, I couldn't find a way. I only find how to change the
version of Windows. I'm on Debian Wheezy using POL 4.1.1 and Wine 1.5.4.

Thanks for your help. Regards,

petch Thursday 24 May 2012 at 1:28


Not really, Wine reports what it detects.
Still, there's a feature in POL that may help Wine detect correct video card:
Clic "Open a terminal" from the Miscellaneous tab in POL Configure panel, type
and try running the game again. Let us know if this helps.
pauldijou Thursday 24 May 2012 at 19:29

Thanks for the tip but it didn't solve the problem. Here is the result of the command line :

It finds a ati .dll file (don't know which vendore/device those id correspond to) but still the error message :

zebastiane Friday 25 May 2012 at 15:35

I have similar problem with a NVIDIA Quadro FX 3450/4000 SDI video card (output from lspci) detected as a NVIDIA GeForce 6200.

The installation worked fine with PlayOnLinux.

I tried to install the VideoDriver package but nothing happened (a window seems to open and get closed immediately after).

Here is the output of POL_Wine_SetVideoDriver where wine find the nv4_disp.dll video driver.

In the registry there are few informations to help me solve the issue.

I run under the 3.2.0 kernel and I have installed the NVIDIA drivers (295.53) on my computer with DKMS.
Quentin PÂRIS Friday 25 May 2012 at 16:31
Quentin PÂRISAnonymous

What if you put 0863 as device id?
zebastiane Friday 25 May 2012 at 19:48

Unfortunately it didn't work.

The identified video card is still NVIDIA GeForce 6200.
Quentin PÂRIS Friday 25 May 2012 at 19:56
Quentin PÂRISAnonymous

Try to add VideoMemorySize 1024
zebastiane Sunday 27 May 2012 at 16:19

I have already tried this, but didn't work too.

Maybe, trying the beta drivers from NVIDIA ? Or having a closer look on nvidia-settings could help ?
edivad Sunday 27 May 2012 at 23:39

Same problem for me, graphic card is Intel

$ lspci -nn | grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09)

but the detected card is "NVIDIA GeForce FX 5600".

I tried changing "VideoPciDeviceID", "VideoPciVendorID" and "VideoMemorySize" but nothing works.
zebastiane Tuesday 29 May 2012 at 14:04

I tried the NVIDIA 302.11 drivers but still nothing new.

After reading this page, I tried to run the specified command and I got :

trace:wgl:X11DRV_WineGL_InitOpenglInfo GL version             : 2.1.2 NVIDIA 302.11.
trace:wgl:X11DRV_WineGL_InitOpenglInfo GL renderer            : Quadro FX 3450/4000 SDI/PCIe/SSE2.
trace:wgl:X11DRV_WineGL_InitOpenglInfo GLX version            : 1.4.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Server GLX version     : 1.4.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Server GLX vendor:     : NVIDIA Corporation.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Client GLX version     : 1.4.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Client GLX vendor:     : NVIDIA Corporation.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Direct rendering enabled: True

This is my video card. Wine seems to detect it correctly, but why Diablo3 does not ?

Edited by zebastiane

Lludw Friday 20 July 2012 at 20:54

I am haveing a similar problem wit POL running on Fedora 17 x86_64 with and ATI Radeon HD4870 x2 graphics card. I get the message: "Diablo III can not run because the graphics card is missing required features. Updating your driver may fix this."
3D Graphix seem to run fine without the vender driver. I am reluctant to use the driver from ATI because it is a kernel modual and every time the kernel is updated the ATI driver has to be uninstalled before the kernel update is applied and then re-installed after the update is applied. That makes for a lot of work when updates to the system are needed so I just stick with the defaults because they work fine.

**Update -- I installed the AMD driver from the ATi web page and it seems to have resolved my issue.

Edited by Lludw

PAfolmer Tuesday 21 August 2012 at 21:16

Hello,i'm new on linux/wine/POL, and Forgive my English
i have a problem similar. In the Register of wine, was put my onboard card (Nvidia with nv4_disp.dll).
So. .. my questions is:
What dll have I got to use for my Ati card?

~$ lspci -nn | grep -i vga
00:0d.0 VGA compatible controller [0300]: NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] [10de:03d6] (rev a2)
02:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Turks [Radeon HD 6570] [1002:6759]

Ubuntu 12.04
Wine 1.5.11
POL 4.1.6