The forum

[Script] Slender

Author Replies
Jump to the page: 1 - 2
KoRnKloWn Sunday 8 July 2012 at 11:26

I'm trying to write a script for Slender, a new free Horror game. It works, [s]however when I run the game the mouse doesn't work for looking around, I was wondering if someone else can try it out and see if they are having the same problem[/s]. If you don't know how, just copy and paste the following script into a text file, and save it. Then in playonlinux under "Tools" choose "Run a local script" and choose the text file you saved with the script in it.

If updating from an older Slender version, first you should uninstall it, otherwise it'll have both version of the game and it'll waste space.

Install Icon

Large Icon

Screen Shot

# Date: (7/8/2012)
# Wine version used: 1.5.9-raw3
# Distribution used to test : Linux Ubuntu 12.04 x64
# Author: Tory Gaurnier
# Licence: OpenSource
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
TITLE="Slender : The Eight Pages"
# Starting the script
POL_SetupWindow_presentation "$TITLE" "Parsec Productions" "" "Tory Gaurnier" "$PREFIX"
POL_SetupWindow_message "$(eval_gettext 'If you have not already downloaded the game, you will need to. You should be able to find it via a Google search, you will need for this script to complete.')" "$TITLE"
# Setting prefix path
POL_Wine_SelectPrefix "$PREFIX"
# Create and setup wine prefix
POL_System_SetArch "x86"
POL_Wine_PrefixCreate "1.5.9-raw3"
# Install game
POL_SetupWindow_browse "$(eval_gettext 'Select downloaded ZIP file here')" "$TITLE"
POL_SetupWindow_wait_next_signal "$(eval_gettext 'Extracting Slender...')" "$TITLE"
unzip -o "$APP_ANSWER" -d "$WINEPREFIX/drive_c/Program Files" || POL_Debug_Fatal "$(eval_gettext 'Sorry, but that was not a valid .zip file')"
POL_Shortcut "Slender - The Eight Pages.exe" "$TITLE"
exit 0

Edited by KoRnKloWn

Quentin PÂRIS Sunday 8 July 2012 at 19:25
Quentin PÂRISAnonymous

Sorry, even if it is a free to play, we cannot accept links to the pirate bay.
KoRnKloWn Sunday 8 July 2012 at 20:28

Really? Why not? The Pirate Bay is not illegal, that is an official download on the Pirate Bay, the developer had to upload it there because so many people downloaded it that their servers ran out of bandwidth.
Quentin PÂRIS Sunday 8 July 2012 at 20:43
Quentin PÂRISAnonymous

I know that. ISOs are not illigal but we do not support them either because 90% of the time, user has a pirated copy

Sometimes, rules are very unfair but we have to respect them
KoRnKloWn Sunday 8 July 2012 at 20:50

OK, so if I remove the piratebay link and just have the web browser link, will it be valid then?
Quentin PÂRIS Sunday 8 July 2012 at 21:25
Quentin PÂRISAnonymous

Not really, mediafire is also not-so-good, we don't really like that because it's not reliable. The script may become broken and we could not notice it.

If I am allowed by the developer, I could upload it on PlayOnLinux's servers
KoRnKloWn Sunday 8 July 2012 at 21:44

It shouldn't break the script because I have it open in the web browser, but you can email the developer here: (from the readme file in the game).

I'll email the developer to explain the situation and ask, and I'll also ask if he has uploaded it to a source I don't know about yet. I'll tell him that he may be getting an email from a Playonlinux admin to ask for permission to upload to your servers.
KoRnKloWn Monday 9 July 2012 at 19:44

OK, I updated the the script to get rid of the download links.
Quentin PÂRIS Tuesday 10 July 2012 at 11:23
Quentin PÂRISAnonymous

If you want your scripts to be integrated to POL, you must submit them (just in case)
KoRnKloWn Tuesday 10 July 2012 at 20:53

Oh yeah, I know, but I was hoping to get it fully working first, but I guess I could submit it under Testing?
xaviorffviii Wednesday 11 July 2012 at 4:21

I'm in the same boat, slender.exe the mouse clicks but can't use it to look around. It's not just a playonlinux thing either, it's something with wine.

If you manage to fix it, pleaaase lemme know! I'm trying to get it to run on my xbmcbuntu htpc, but it's no good if I can't look around :(.

I'm starting a thread at winehq to see if someone there knows whats going on, I've tried three different versions of wine with no luck (1.3.8(I think?), 1.4, and 1.5.8)

It would be incredible if we got this to work, maybe contact the application developer and see what he has to say about it?

KoRnKloWn Wednesday 11 July 2012 at 16:56

I already contacted the developer, he just made it with Unity3d (unrelated to Ubuntu Unity), so he doesn't know much else about it, and I tried looking up Unity3d games in Wine, but all that comes up is running Unity3d itself in Wine.
xaviorffviii Wednesday 11 July 2012 at 18:15

Oh well, this is really going to bother me, cause the game loads fine, it's just the mouse. I'd be less upset if the game didn't work at all haha. But I suppose if it's just one problem, it can be fixed, just have no idea how, I'm new to wine and playonlinux so I have no idea what I'm doing.

There is a workaround though, if the game could be changed or have the option to use the left right up down keys for looking, then it would work fine. Could easily map those to a ps3 joystick and it would work great I think.

Perhaps the developer would sympathize enough to help us on that? Since it does work in wine so well, a lot of people on linux could play it fairly easily, that's a big swath of people too.

Edited by xaviorffviii

KoRnKloWn Thursday 12 July 2012 at 21:24

That would actually be a fix, but I really don't know if the developer would be willing to go through that work for linux, and I'm not sure if you can, I'd think you could, but I really don't know how Unity3d works, I know it's sort of like a WYSIWYG (What You See Is What You Get) IDE for video games, and I'm not sure what features it has. On another note, I know the newest version of Unity 3d, Unity 4, will support publishing your games to linux, so if he upgrades his Unity, then we may get a native Linux build, but I'm not keeping my hopes up, since Unity isn't exactly a cheap program...
KoRnKloWn Thursday 12 July 2012 at 21:24

And I know, it's driving me crazy too -_-
xaviorffviii Friday 13 July 2012 at 3:15

And I know, it's driving me crazy too -_-

Quote from KoRnKloWn

Drive yourself crazy no more!

A member at winehq notified me of a possible patch to try and it works!

Heres the conversation from the thread


Joined: 28 Nov 2010
Posts: 72

PostPosted: Thu Jul 12, 2012 6:48 pm    Post subject: Reply with quote

Have you tried applying the "raw3.patch" that is described in the following bug report?
Back to top
View user's profile Send private message  

Joined: 10 Jul 2012
Posts: 3

PostPosted: Thu Jul 12, 2012 7:14 pm    Post subject: Reply with quote Edit/Delete this post

Very Happy That did it!
I used playonlinux to test it and it works!
I used 1.4-rc4-raw3 under tools and manage wine versions.
I may manually patch it for my xbmc htpc though, may be easier than figuring out how to launch it from xbmc using playonlinux.

Thank you so much ischou! I think there's gonna be a lot of linux users that are going to be happy they can play slender.exe.

Thanks so much again!
KoRnKloWn Monday 16 July 2012 at 21:47

And this is why forums are great :D I'm updating the script as we speak as this is a REALLY fast fix, all I have to do is update the version of wine it uses, because Playonlinux is great and already has a ton of patched wine versions :]

I'll update the script here as soon as I test it.
KoRnKloWn Monday 16 July 2012 at 21:56

It works!!! :D
I updated the script above, now anyone should be able to run it. Now if only I didn't have a crappy intel chipset... :(
KoRnKloWn Monday 16 July 2012 at 22:36

Ok, I added the icons and screenshot to the post, so if an admin could update the script, take it out of the 'testing' section, and add the screenshots, that would be great ^_^
Quentin PÂRIS Tuesday 17 July 2012 at 17:34
Quentin PÂRISAnonymous

Sorry, your images are not valid