The forum

Diablo 3 Crashes During Play

Author Replies
donner Sunday 2 September 2012 at 0:59


I installed Playonlinux today and installed Diablo 3 from the DVD and everything works great.  Sometimes when I enter a new area such as cellar, cave, cathedral etc. it crashes but saves where it crashed.

Any ideas on how to prevent these crashes during the game?


Linux MInt 13 MATE 32-bit
Gigabyte HD6670 video card
AMD Phenom XII
donner Tuesday 4 September 2012 at 4:02


The game is now running for about 1-5 minutes and then getting slower and slower and then completely stops. I have not changed anything on my computers settings or updates.

Linux1138 Tuesday 11 September 2012 at 21:56

I have the same/similar problem with Diablo 3 freezing/crashing/locking up my pc.

Wine version: 1.5.5 DiabloIII_v3

Playonlinux version: 4.1.7 (opengl, 1024 video memory)
Distribution: Fedora
Distribution version: (Lovelock)
KDE 4.6.5 (Desktop Effects are not enabled)

Mother Board: Gigabyte MA770T-UD3P

CPU: AMD Phenom II X4 965 (Black Edition)

Memory: 12 gigs DDR3 1600MHz

Graphics card: ATI 5850
Graphics card driver: Catalyst Version 11.7

Driver Packaging Version 8.872-110707b-122669C-ATI

2D Driver Version 8.91.4

OpenGL Version 4.1.11251

The ATI drivers were not installed using the ATI installation procedures from AMD/ATI.

They were installed as follows as root from a Konsole Terminal:

  1. Enable RPMFusion's repository.

    1A. rpm -Uvh

  2. yum update - reboot after update is done as you will most likely have new kernel version.

  3. yum install gcc kernel-devel kernel-headers - reboot.

  4. Install Graphics driver.

    4A. yum install akmod-catalyst kmod-catalyst xorg-x11-drv-catalyst xorg-x11-drv-catalyst-devel xorg-x11-drv-catalyst-libs

    This will/should install your 64 bit fglrx driver in the /usr/Lib64/dri and ~xorg/directories and create your xorg.conf file under /etc/X11.

  5. Reboot

  6. glxinfo | grep direct – should return Direct rendering: Yes

  7. yum install xorg-x11-drv-catalyst-libs.i686

    This will install your 32 bit fglrx driver in the /usr/Lib/dri and no xorg/directories.

If I do yum update there is nothing to update (even if I try to specifically update catalyst they all return “nothing to update you have the latest version”).

Both glxgears and fgl_glxgears work fine and give good FPS numbers. The system is stable and runs a variety of software (including some Linux games like Nexuiz).

I have been playing WoW (prior to 5.0.4 patch) with just Wine 1.5.3 using -opengl – launch. The FPS was poor but it did not lockup/freeze the pc. With the “New” Launcher/Agent from Blizzard, WoW no longer plays. MoP beta will not play and I got Diablo 3 to actually login and run once before the system locked up. Now with all the help from others, the newly compiled Wine and your Playonlinux I have no problem getting to the login and actually starting a Diablo 3 game. The only problem I have is it will lockup the pc anywhere from a few seconds to the most 10-20 minutes (the loading of new screens is very bad like when you are just moving around. The images will just freeze for a second then load then it will be ok to move etc.). Even if I just start Diablo 3 then exit and close everything normally, my system will eventually just freeze (mouse can move and if any sound was playing I still hear it but nothing else works. I have to hard reset).

I have 2 Hard drives/Dual boot system. Windows 7 64 bit with Diablo 3 installed and running fine and Fedora 15. I removed all traces of Wine from my system and installed Playonlinux fresh (which also installed Wine1.5.3). I had to install icoutils to get rid of the 2 errors when starting Playonlinux (no icotools and no wretools). I installed Dibalo 3 from my mounted Windows drive using the known good install files (if I knew how to just copy over the working Diablo 3 game and set it up in Playonlinux I would of done that). Playonlinux installed/setup Diablo 3, Wine 1.5.5, Gecko, Fonts, vcrun2008 etc. just fine.

If I left the Direct Draw Renderer set to default or gdi I would get Russian looking characters on the login screen and beyond so I use opengl. I also tried setting Wine to Windows 7 but the game still locked up my pc.

I looked over the logs (playonlinux.log, Diablo III.log - same logs) and there are many “fixme” lines (I was getting a lot of those from just using Wine before as well). The files are 57mb so I can't list them here but would be happy to upload them somewhere.

Please let me know what other information you would like to help debug the freezing/pc locking up or anything you want me to try.


Edited by Linux1138

Maguvaskirn Saturday 22 September 2012 at 18:25

I faced the same issue, sometime also after several minutes, but now it seems solved.

Here is my quick fix advice which of course works perfectly for me: 1. kill the xscreensaver daemon; 2. disable the xcomposite extension from your window manager.

Here is my actual config (by reusing Linux1138 cool list :) ):

Wine version used in POL: 1.5.9 (from the v1.5.10 I see strange artifacts during playing)

Playonlinux version: 4.1.7
Distribution version: Linux Gentoo 3.3.8-gentoo #1 SMP i686 Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz GenuineIntel GNU/Linux
Xfce 4.10

Graphics card: ATI 5850 BE

Graphics card driver: Catalyst Version 12.6

Diablo 3 longest continuous play time: 2h 30m

egelor Sunday 23 September 2012 at 5:11

Playonlinux: 4.1.8
wine: 1.5.5-diablo_v3 and v2 tested
Distribution version: Ubuntu 12.04 pressise
Graphic card: Nvidia 9200m
After the last update of Ubuntu my nvidia crashed. I rebuilt it.
After the last update of playonlinux i cant play anymore.
From the configure botton i open the games folder and when i run it from there the game opens but after some min in action house connection lost. So maybe is something with wine 1.5.5 diablo cause 1.5.3 opens diablo as i said for a while.
Thank you.

Edited by egelor

donner Sunday 23 September 2012 at 5:29


How do you do #1 and #2 that you mention above?

Maguvaskirn Sunday 23 September 2012 at 13:07


How do you do #1 and #2 that you mention above?


Quote from donner

I suppose it depends on your graphics environment. Anyway in Xfce from the main Xfce menu (the one with the image of the black mouse):

#1 -> go to settings and between all the choices you may find 'xscreensaver'; left click on it then in the new window menu 'File' and choose kill daemon. Anyway I suppose you can ps -ef | grep xscreen and then kill it by yourself... of course some desktop environment in case of forced kill will automagically reinstantiate it so I strongly advise to proceed via desktop environment.

#2 -> go to settings and between all the choices you may find 'Window manager settings'; left click on it then in the new window you'll be able to see a tab named 'Compositor'. Click on it and disable it.

Please note that after #1 and #2, just to be sure, you should restart your system.

Please note anyway that I solved the crash issue by not using the POL suggested wine version, but the 1.5.9.

Good luck.
egelor Sunday 23 September 2012 at 23:18

This is the fix for me! for the ERROR CODE BLZPTS00007
I was able to get this working today. If you navigate to the folder (I'm using Win7, so it's in the C:\\ProgramData\\ and remove it, then run the install file again, it should work. The ProgramData folder is normally hidden, and you'll need to "view hidden files" in folder permissions to see it.
It looks as though the Agent program that is responsible for downloading updates can get corrupted pretty easily. I moved that folder to a different location, ran the install file again, and everything started running normally again. Hope that helps anyone else.

Edited by egelor