The forum

Skyrim & Ubuntu

Not Stable Enough

Author Replies
bmangamer Friday 11 January 2013 at 2:31


I have been trying to get Skyrim to play on my Ubuntu 12.04 system. I ran the setup with Playonlinux and everything seemed to go fine.

The first issue I ran into was it was asking for some type of file, I assumed this was because of my drivers because at the time I didn't have the AMD ones installed. So I installed the latest 12.11 beta (I believe that is the latest) and it worked.

So now my issue is that when I start the game (using the Steam version) it will get to the main page of the game, when I click continue to start the game, it will load and continue to load.

I have tried it 5 times now, 3 of them have frozen and nothing can be done. I don't know any commands in Linux to quit it, so I have to hit the reset button on my system to get out of it. The other 2 times it actually loads into the game.

Now inside the game it is running quite weird. I don't want to say slow but I don't have another explanation for it. The mouse movements are the main issue, very jaggy and slow, and just overall not the experience I know from Windows.

And the second time it worked, I ran around for awhile, about 5 minutes and then it froze and had to reboot the system. I followed the information available on this site about a few settings that can be changed, and none of it made a difference. Though I couldn't find the settings area for 

"b) Check if you've got 3D acceleration 
-go to Settings->System 
-press GLXInfos and search for "direct rendering: Yes" 
-press 3D Test and after 20 seconds close it "

Though I have a feeling if it was set to no my game wouldn't start at all.

I know it's not my system because I play it on High settings (have it set to medium on this) without issue.

I have a 

Intel Core 2 Quad 2.6Ghz
Lots of Drive space
ATI Radeon HD 5850 1GB video card.

Not sure if I am forgetting any information, please ask if I did.
bmangamer Tuesday 15 January 2013 at 2:26

Quite a bit of views and no comments.

I guess I am out of luck?
Skyrim Tuesday 19 March 2013 at 3:00

I solved my audio and video issues by running the directX executable that is in the Skyrim install folder.
Ronin DUSETTE Tuesday 19 March 2013 at 3:41

Yeah. Sorry for the late response.

That is correct. It didnt have d3d set up.

Next time it needs 3d, though, you can install d3d itself correctly by using PlayOnLinux's Install Components. Its more than likely that the audio issue was being caused by your computer working overtime, probably trying to software render the game.

Glad you got it fixed. The forum has become more active lately, so hopefully it will not take as long to get back to you. :)

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
You are here: Index > PlayOnLinux > Skyrim & Ubuntu