Forums

League of Legends cannot login as of 4.17

Auteur Réponses
GenerallyBreak Samedi 27 September 2014 à 21:10
GenerallyBreakAnonymous

After the 4.17 patch a few days ago the League of Legends client now reports that it failed to get a response from the login server (with 3 retries each spaced about a second apart.) This error seems to happen the same way on every Wine version recent enough to run the client.

My log is at: http://pastebin.com/ZbEnaCka

Running Gentoo Linux. Probably of note is that a friend running Ubuntu 14.04 does not have this issue.

Also probably of note is that if I convert the prefix to 64-bit and use a 64-bit Wine it does not have this issue (though the 64 bit versions have their own issues later on that seem unrelated)

Thanks!

jdgallag Dimanche 28 September 2014 à 4:59
jdgallagAnonymous

I second this.

 

When logging on, I get past the update client, to the login screen.  I enter username and password, and I get an "authentication successful" message.  And then "logging in".  The "logging in" message seems to hang around for a while, and then I get a connection error every time.

skullbad Mardi 30 September 2014 à 18:07
skullbadAnonymous

Hey,

 

Was there any solution to this? I still can't play and I want to get my league fix in soon. I have scrims coming up 0_0. I'm having the same exact problem and tried many different versions.

GamerFatale Mardi 30 September 2014 à 19:43
GamerFataleAnonymous

Same here.  Using "1.7.24-LeagueOfLegendsCSMT" i can login but i can't use the Ingame shop.  But before with the "1.7.19-LeagueOfLegends2" I could play perfectly.  But now i can't even login :(

Edité par GamerFatale

skullbad Mardi 30 September 2014 à 21:58
skullbadAnonymous

So I got this working by changing my League version to 1.7.27! Go to playwithlinux then configure and download 1.7.27 if you don't already have it then change it to that. I hope this helps anyone who hasn't solved it yet!

izberion Mardi 30 September 2014 à 22:24
izberionAnonymous

I was having problems with logging in. Fiddling with wininit fixed it, but I was getting crazy bugsplats. Only way I fixed that was reinstall.

GamerFatale Mercredi 1 Octobre 2014 à 2:23
GamerFataleAnonymous

I fix everything using "1.7.19-LeagueOfLegends" eve the ingame shop

skullbad Mercredi 1 Octobre 2014 à 18:20
skullbadAnonymous

Awesome! worked perfectly I appreciate it :)

petch Mercredi 1 Octobre 2014 à 21:19
petch
Développeur

If it works with 1.7.19-LeagueOfLegends, try uninstalling 1.7.19-LeagueOfLegends2, reinstall it, and give it a second chance.

The hypothesis being that 1.7.19-LeagueOfLegends works just because you recently installed it, so you benefit from a fix that was done across all recent Wine packages only several weeks ago.