The forum

League of Legends cannot login as of 4.17

Author Replies
GenerallyBreak Saturday 27 September 2014 at 21:10

After the 4.17 patch a few days ago the League of Legends client now reports that it failed to get a response from the login server (with 3 retries each spaced about a second apart.) This error seems to happen the same way on every Wine version recent enough to run the client.

My log is at:

Running Gentoo Linux. Probably of note is that a friend running Ubuntu 14.04 does not have this issue.

Also probably of note is that if I convert the prefix to 64-bit and use a 64-bit Wine it does not have this issue (though the 64 bit versions have their own issues later on that seem unrelated)


jdgallag Sunday 28 September 2014 at 4:59

I second this.


When logging on, I get past the update client, to the login screen.  I enter username and password, and I get an "authentication successful" message.  And then "logging in".  The "logging in" message seems to hang around for a while, and then I get a connection error every time.

skullbad Tuesday 30 September 2014 at 18:07



Was there any solution to this? I still can't play and I want to get my league fix in soon. I have scrims coming up 0_0. I'm having the same exact problem and tried many different versions.

GamerFatale Tuesday 30 September 2014 at 19:43

Same here.  Using "1.7.24-LeagueOfLegendsCSMT" i can login but i can't use the Ingame shop.  But before with the "1.7.19-LeagueOfLegends2" I could play perfectly.  But now i can't even login :(

Edited by GamerFatale

skullbad Tuesday 30 September 2014 at 21:58

So I got this working by changing my League version to 1.7.27! Go to playwithlinux then configure and download 1.7.27 if you don't already have it then change it to that. I hope this helps anyone who hasn't solved it yet!

izberion Tuesday 30 September 2014 at 22:24

I was having problems with logging in. Fiddling with wininit fixed it, but I was getting crazy bugsplats. Only way I fixed that was reinstall.

GamerFatale Wednesday 1 October 2014 at 2:23

I fix everything using "1.7.19-LeagueOfLegends" eve the ingame shop

skullbad Wednesday 1 October 2014 at 18:20

Awesome! worked perfectly I appreciate it :)

petch Wednesday 1 October 2014 at 21:19

If it works with 1.7.19-LeagueOfLegends, try uninstalling 1.7.19-LeagueOfLegends2, reinstall it, and give it a second chance.

The hypothesis being that 1.7.19-LeagueOfLegends works just because you recently installed it, so you benefit from a fix that was done across all recent Wine packages only several weeks ago.