The forum

3D acceleration warning

Author Replies
hasi Monday 21 January 2008 at 16:16
hasiAnonymous

I am using PlayOnLinux in a professional environment (not for games). I am using a dual monitor setup (xinerama mode). In this mode, OpenGL is not supported (I would be happy to be proven wrong!). I suppose that this is the reason why I am getting this "You don't seem to have 3D acceleration! We advise you get it." warning every single time I start MS Word (essentially, every time I click to open an Word document).
Is there any way that this warning could be switched off? I would be happy by changing some setting in a config file. Ultimately, of course, it would be nice to have a button or an option in the PlayOnLinux GUI to turn it off.
Any ideas?
--hasi.
Quentin PÂRIS Monday 21 January 2008 at 17:06
Quentin PÂRIS
Admin

Edit /usr/share/playonlinux/lib/check_depend

cfg_check ()
{
     programmes_check
     acceleration_check
}

Put a # behind acceleration_check
hasi Monday 21 January 2008 at 17:56
hasiAnonymous

Done! It works. Thanks so many times for one more very quick and very efficient response.
--hasi.
Lachu Saturday 26 January 2008 at 18:33
LachuAnonymous

I have another method:
Change the same line as post above, but as follows:

if [ ! "$TMP_ACC_CHECK" ]; then acceleration_check; export TMP_ACC_CHECK="1"; fi

It should to view these message only in star of PlayOnLinuxt.
Quentin PÂRIS Saturday 26 January 2008 at 18:50
Quentin PÂRIS
Admin

Very good !

It will be in Pol 2.0.7

Edited by Tinou

hasi Saturday 26 January 2008 at 22:23
hasiAnonymous

Great! Thanks!