The forum

Not enough disk space error

while installing Assasin's Creed

Author Replies
aamadis Saturday 30 March 2013 at 11:33

I keep getting this error, no matter what drive or folder I choose to install in, and it always says I need the same amount of space (2789 MiB) no matter what size drive, and I even have a mostly empty 1TB drive available. Did i do something wrong?
petch Saturday 30 March 2013 at 12:02

Can you tell what's the output of
$ df -P -k
run in a terminal?
aamadis Saturday 30 March 2013 at 17:48

Filesystem 1024-blocks Used Available Capacity Mounted on
/dev/sda5 80652064 73696712 2858380 97% /
udev 3073296 4 3073292 1% /dev
tmpfs 1232424 1196 1231228 1% /run
none 5120 0 5120 0% /run/lock
none 3081052 76 3080976 1% /run/shm
none 102400 60 102340 1% /run/user
/dev/sda2 39106992 27157452 11949540 70% /mnt/22247D8E247D6627
/dev/sdb1 976760828 121788 976639040 1% /media/axxxxxxxxxs/Bxxxxxxxa

Edited by aamadis

Ronin DUSETTE Saturday 30 March 2013 at 17:50

Which drive are you trying to install it on? It shouldnt be outside of your ~/.PlayOnLinux folder. Are you trying to mount it to the one that is at /media/adriene-amadis/ ? If so, is that an NTFS drive?

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
aamadis Saturday 30 March 2013 at 23:05

I tried both. First the main drive (which was selected by default) and then the other (yes, it is NTFS). Neither worked.

If I am supposed to direct the wizard to install the game on my ~/.Playonlinux folder I don't know how to do that as that's a hidden folder and doesn't show up in the Windows style folder browser.
visitntx Sunday 31 March 2013 at 18:26

What distro are you using? Arch based use systemd to control tmpfs as half of your ram insteed of disk space. At the sam time when it tells you about the full disk, without closing the error, in a terminal do a "df -h" and look if one of them is at full right there.
aamadis Sunday 31 March 2013 at 18:41

I'm using Ubuntu 12.10.
aamadis Sunday 31 March 2013 at 19:21

Ok, I think I see the problem.I have a smaller ssd that has my Ubuntu install on it and a larger hdd for storage and extra stuff. Right now my home folder, where PlayonLinux is installed, has only 2.4 gb of free space. Not enough for this game or any other games I may want to install in the future. so it seems I need to install POL to the second drive. I think I'l need to create a ext4 partition on there as well? I know how to do that, but how do I get POL to install on the second drive? I'll need POL to always use the second drive as the default location, right? That way games will always be able to see the virtual drive and install into the default folder within POL.
aamadis Sunday 31 March 2013 at 19:55

Now that i understand the problem better I was able to find the solution (sort of) within the forums. I need to make a "symbolic link". Hadn't heard that term exactly before. Is that just a normal link? And do I link the entire ~/.PlayonLinux folder, or another folder within that folder. I'll play around and see. Otherwise it looks like I'm going to have to move my home folder off of the ssd to the second drive. A bit more compicated, but I found a guide on doing this in Ubuntu.

Marking this as solved, and thanks for your help. Wish me luck!