The forum

Mouse problem

Author Replies
Pinata Wednesday 17 April 2013 at 16:03
PinataAnonymous

Hello,

I have a problem with a game (Path of Exile) I'm playing on PlayOnLinux. I wanted to be able to alt-tab out of this game, but found out this wasn't possible, but I've got a solution for this. With Compiz it is possible to switch workspace by pressing ctrl+alt+left/right arrow. Unfortunately, my mouse still acts like I'm in the game when I do this, so I can't click anything, and my cursor still looks like the ingame one (while it should be the default cursor I suppose).
Doe anyone know a solution for this?

I'm running Linux Mint 14 Cinnamon (x86), on an Asus K52JC laptop. 
I have the latest Wine version (1.5.28)
I'm not getting any error message or something.

Kind regards,
Pinata

Edited by Pinata


~Pinata

LoL - Euw: Hallelujahh
booman Thursday 18 April 2013 at 0:07
booman

Hey fellow Mint user...
switching workspaces should work, but I have experienced instances where it doesn't.
I would try combinations of ctrl+alt+left/right and alt+tab just to get out-of-game.
My final option was to run the game in a Virtual Desktop (Wine Configuration) and match my desktop resolution to that in the game.
This way it appears to be full-screen but you can still switch out of the game with keyboard shortcuts.

Let me know if this doesn't work.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
krissi Thursday 18 April 2013 at 1:56
krissiAnonymous

.

Edited by krissi

booman Thursday 18 April 2013 at 1:59
booman

Yeah, I have noticed bugs with resolution too.
When quitting some games your desktop stays the resolution that was set in-game.
So I always have to set it back.
Not sure what thats all about.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Thursday 18 April 2013 at 2:05
Ronin DUSETTE
Admin

@krissi - Why delete your post? :( Now when future users search for something like this, we have an answer, and no question. lol

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Pinata Thursday 18 April 2013 at 11:18
PinataAnonymous

@booman - Works as a charm, exactly what I wanted. Though, a new problem came up with this solution.

I'm running linux on my Asus K52JC, which uses Nvidia Optimus technology. Now, when I use optirun (or primusrun) when starting the game, the virtual desktop will be ran with my high-end nvidia graphics card, but the game itself will be run on the Intel HD graphics card (which isn't capable of running it)...

(Bumblebee is installed properly, and running)

Thanks in advance
Pinata

Edited by Pinata


~Pinata

LoL - Euw: Hallelujahh
booman Thursday 18 April 2013 at 17:22
booman

Whoa! Never saw that kind of problem before. Really strange, why would the game run with Intel integrated graphics if Wine is using your Dedicated Video Card?

Kinda cool if you think about it. But, I would disable your integrated Intel graphics in the BIOS.
Sounds like you are using a laptop, correct?
Ah, after some research I see whats going on... You are using an Intel CPU with integrated GPU. Also, you have a dedicated card in your laptop and they are conflicting.

I honestly don't know how to disable the Intel GPU because its part of the Processor.
I would have to do some research. Interesting because I see this being a problem with dedicated graphics cards.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Thursday 18 April 2013 at 17:42
booman

Ok, I found forum post on someone having similar problems with your laptop.
[url=http://www.minecraftforum.net/topic/79742-solved-laptop-under-performing-low-fps/]Asus K52JC[/url]

Okay so I figured out the problem, my laptop has nVidia Optimus Technology, which allows you to alternate between an integrated Intel graphics card and an nVidia GeForce card to save battery life or something.

Initially I figured it may be running minecraft on the integrated graphics card, so I changed the settings so minecraft.exe would run through the nVidia graphics. This didn't help, but I didn't think to add java itself to the list. Once I'd set java to run with the nVidia card it works perfectly.

Step-by-step.
1. Right-click on desktop and click NVIDIA Control Panel
2. Select 'Manage 3D Settings' in the left pane
3. Select the "Program Settings" tab in the main window
4. Click 'Add'
5. Navigate to your java folder (C:/Program Files (x86)/Java/jre6/bin) and select javaw.exe and press 'open'(this step will probably depend on your operating system but should be pretty easy to find)
6. Where it says 'Select the preferred graphics processor for this program' click the drop-down and choose 'High Performance NVIDIA processor'
7. Click 'Apply' in the bottom right and you're good to go.

Quote

Since you are in Linux, use the Nvidia control panel and look for these similar settings.  Instead of Java, look browse for Wine or your game.
But don't be surprised if you don't see these settings in Linux because Nvidia may not have added them yet.

Edited by booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Thursday 18 April 2013 at 18:01
booman

Looks like you may have an option in the BIOS on your Asus laptop, but when you set Nvidia Dedicated Card as your primary graphics, you will need to install Nvidia's drivers to get the performance.
Otherwise, Linux will default to the Nouveau driver.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Pinata Friday 19 April 2013 at 0:49
PinataAnonymous

I have done some research on this part also (while I was still running windows), and it unfortunately is not possible to disable the intel card. All the nvidia card does, is give his power to the intel card, but it doesn't render images itself. In linux, you don't select the card you want to run a program with, but it will go for the intel card always, unless you add a prefix 'optirun' to your command.

I might try to install the nvidia driver in my wineprefix though, and if that works, I should be able to assign my nvidia card to the gamd trough the windows virtual desktop. I'll try that tomorrow, when I'm on my laptop. :)

Thanks for your help so far, and I'll keep you updated :)
Pinata

~Pinata

LoL - Euw: Hallelujahh
Ronin DUSETTE Friday 19 April 2013 at 0:56
Ronin DUSETTE
Admin

I doubt that installing Windows Nvidia drivers into your Wine prefix will not work. Thats not how those drivers work. Wine is not an emulator. It will pass as much as it can to Linux, as native as it can. Your GFX card drivers and libraries need to be in Linux, or invoked through Linux. Most likely the driver install will fail.

Although, let us know if it works. :)

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Pinata Friday 19 April 2013 at 10:22
PinataAnonymous

Okay, just turned my virtual desktop back on, and now it seems to work properly, without any update! :)

So concluding my solution: Just turn on Virtual desktop, and you can change workspace with ctrl+alt+arrow left/right.)

Thanks for the help!

Kind regards,
Pinata

~Pinata

LoL - Euw: Hallelujahh
booman Friday 19 April 2013 at 14:17
booman

No problem! Feel free to post any other questions and don't forget to mark "Solved"

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
You are here: Index > PlayOnLinux > Mouse problem