The forum

SC2 HOTS mouse cursor glitch & hotkeys

Author Replies
set_me_free Wednesday 11 December 2013 at 1:32
set_me_freeAnonymous

Hello!

First of all I'd like to say that playonlinux is amazing and I've come a long way in getting everything to work, even though I have only been using linux for a few days. However I think I need some help with the couple of problems:

- the mouse cursor currently is glitched, the game runs flawlessly and all graphics are working fine, except for the mouse cursor which is some kind of single color blob. Anyone have an idea what could possibly fix this? (It should look like this: http://img411.imageshack.us/img411/2902/60620237.png)

- KDE has some hotkeys like CTRL F2 that are rather vital for playing sc2. Whenever I press these hotkeys I essentially tab out of the game. Is there any solution to disable these hotkeys just while playing without rebinding them all? I've looking into starting SC2 in its own X or is there a simpler way?

I am using:

Linux Mint 15 KDE
Playonlinux 4.2.1 and Wine 1.7.1-CSMT (which actually yields higher fps than I got in win7)
amd-catalyst-13.11-beta-v9.4-linux-x86.x86_64 (R9 280X)

I used this script to install the game which went rather smoothly: http://www.playonmac.com/en/topic-10546.html

Some problems I got past, which might help other people:

- "black screen, only see mouse cursor" after launching the game, fixed by installing the graphics drivers listed above

- performance issues, performance was at rougly 50% of what it should be, tested 1.7.1-CMST (via playonlinux) with HKCU/Software/Wine/Direct3D/CSMT = "enabled", which more than doubled the fps with all settings

- no sound ingame, only had sound when testing in wine configuration and the sc2 game launcher (hovering over the orange play button). cause:

found this error message in the debugger:

    "patch_applicaALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default

fix:

sudo apt-get install libasound2-plugins:i386

(found here: http://ubuntuforums.org/showthread.php?t=2173755)

Thanks in advance for any help you can give me!

booman Tuesday 17 December 2013 at 18:19
booman

Thanks for posting solutions to problems in Mint.
I use Mint as well and have a lot of success with games.

By the way, we have a step-by-step guide on StarCraft II:  Starcraft II Guide

I think you will find some good tips for manually installing games and selecting the proper libraries to get it running.

Normally mouse/keyboard problems can be fixed by using a Virtual Desktop.
You can configure this by using Wine Configuration in the Graphics tab.

† Booman †
Mint 21.3 64-bit | Nvidia 535| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
set_me_free Wednesday 18 December 2013 at 22:30
set_me_freeAnonymous

Thank you booman. With your help I was able to fix the KDE hotkey problem.

Fix: run a virtual desktop in the wine configuration graphics tab, run the virtual desktop, right click the window bar, select more actions and then special window settings. Under appearances & fixes one can disable global shortcuts "force" & "yes".

I also tried to follow your guide and install the same libs. I was able to install vcrun2005, but the other 2 (corefonts and videodriver) just immediately close again after selecting them.

I still have that mouse cursor glitching problem. It seems the mouse cursor is completely seperate from all the other graphics in the game (I also ran into problems earlier where I would only see the cursor and the rest of the screen would remain black).

Im switching to Mint 16 around xmas, if I dont find a solution until then I will give that guide a go and see if that fixes it.
booman Friday 20 December 2013 at 0:50
booman

Awesome, I'm glad some of my tips helped.
Are you installing the libraries in a 32-bit virtual drive?
I always manually install games in a 32-bit virtual drive since most games are 32-bit compatible.

As for the mouse problem, did you try the mouse override options in the PlayOnLinux miscellaneous tab?
I havn't used it in a while, but sometimes enable or force can help fix the mouse coordinate issues.

† Booman †
Mint 21.3 64-bit | Nvidia 535| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
set_me_free Saturday 21 December 2013 at 22:49
set_me_freeAnonymous

You are a genius. Thank you so much!!

Setting the "mouse warp override" to "enable" fixed the cursor glitch.

Next challenge: Hearthstone. I already followed that other thread. I have a feeling that will be interesting :)
booman Monday 23 December 2013 at 19:24
booman

Cool, glad it worked. Strange because I havn't used that in a long time.
Normally the Wine mouse checkbox worked for me.

I have heard positive and negative results about Hearthstone.
Feel free to post your bugs!

Don't forget to set this thread as "solved"

† Booman †
Mint 21.3 64-bit | Nvidia 535| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained