The forum

Starcraft 2

Author Replies
ziom155 Wednesday 29 January 2014 at 15:30

Hi. I installed sc2 on my ubuntu 13.10 and after downloading game to "playable" i ran it. When the login sceen appeared, i typed my e-mail and tried to log in and got a message: "Unable to connect to" (or something in this way, i haven't english version of game). I tried to log in a few times in a few different hours and still the same information. How can i fix it?
P.S.: Please dont flame me if my english is bad
Daerandin Saturday 1 February 2014 at 13:13

Did you disable ptrace protection before running the game?
ziom155 Saturday 1 February 2014 at 13:53

What is this and how can i disable it?
Daerandin Saturday 1 February 2014 at 14:16

ptrace protection is a kernel security feature present in many distros. Googling for it should provide lots of information on it.

To check if it is enabled on your system, open a terminal and run

cat /proc/sys/kernel/yama/ptrace_scope

If the terminal output is 1, that means it is enabled. Any other output than 1 means it is not disabled for you.

To disable it, type this in terminal:

echo 0 | sudo tee /proc/sys/kernel/yama/ptrace_scope

You will be asked for your password as it requires root privileges to edit that file. If you want to enable it again after playing, then run:

echo 1 | sudo tee /proc/sys/kernel/yama/ptrace_scope
ziom155 Saturday 1 February 2014 at 14:45

It didnt help ;/
Any other ideas?
Daerandin Saturday 1 February 2014 at 14:48

If disabling ptrace didn't help, then I would have to know how you installed the game. Did you use the PoL script, or did you install it manually?

DVD install or did you use the digital edition from
ziom155 Saturday 1 February 2014 at 14:52

I intalled it 2 times: 1st with PoL script and 2nd with this guide(i got 2nd "version" now).
I moved files (it was around 10-20% downloaded) from Windows. Can it be a reason?
If not, what can be?

Edited by ziom155

Daerandin Saturday 1 February 2014 at 14:59

Moving from windows could be a problem but I am not sure. It would depend on if the installation for Starcraft 2 has some differences in configuration depending on windows version. Both the PlayOnLinux script and the guide you referred to have windows version set to windows xp. In many cases it should not present an issue, but I would suggest you let the installer download the whole game to rule out this as a problem.

If you followed the guide to referred to, that means you should have disabled ptrace protection as it is clearly stated at the beginning of the guide that you should do this.

As for the rest of the installation, are you sure you followed all other steps?
ziom155 Saturday 1 February 2014 at 15:35

I think i did everything what was neccessary. Now i dont know if i have windows xp version in wine. Ill try disable protection at start and install it again and download full without making a copy.
When i do this, ill post there.
Daerandin Saturday 1 February 2014 at 19:08

I tested the game myself just now to make sure that a recent update didn't break things. The game patched and ran without issues afterwards. However, I saw there was a new notice besides the login after the game starts, stating that Blizzard is having issues with their authentication servers that can cause slow login or failed login.

I don't know if this has been present since you first attempted installing the game, but there is a chance that you are experiencing this problem. If you follow all steps in the guide to no avail, then I think it would be an idea to wait until Blizzard has resolved the issue with their authentication servers, just to rule that out.
ziom155 Sunday 2 February 2014 at 17:35

I played sc2 on another coputer (but with Windows) and it ran without problems, so i don't think that I've got problems because of Blizzard.
You are here: Index > PlayOnLinux > Starcraft 2