The forum

Civilisation V: "comctl32.dll" failed to initialize

Author Replies
rhalina Monday 31 March 2014 at 22:23

maybe you guys can give me a hint where to look next. I successfully installed Civilisation V on PlayOnLinux (4.2.2 Debian testing). When trying to run the game (wine version 1.7.15) I get the following error:

[03/31/14 22:20:11] - Running wine-1.7.13 CivilizationV.exe (Working directory : /home/rhalina/.PlayOnLinux/wineprefix/Civ5/drive_c/Sid Meier's Civilization V)
err:module:attach_process_dlls "comctl32.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Sid Meier's Civilization V\\CivilizationV.exe" failed, status c0000005

I already tried reinstalling on a fresh wineprefix and checked wheather the comctl32.dll is there (it is ~/.PlayOnLinux/wineprefix/Civ5/drive_c/windows/system32/comctl32.dll).

I'm using a Thinkpad X230 with integrated Intel chipset (I think intel hd3000).

NeverWinterNights 1 works fine btw.

Ideas anyone?
booman Friday 4 April 2014 at 22:08

Did you do a manual installation or use a PlayOnLinux script?
I'm asking because I was wondering which libraries you installed...
WineHQs claims that you need:
  • d3dx9
  • vcrun2008
So I'm hoping comctl32.dll is part of one of those libraries.

Looks like the error is about Microsoft Common Controls
Not totally sure what that is, but If you set your Windows version to Windows XP and install Internet Explorer 8

Like you said, its already there, but maybe its one of Wine's libraries trying to copy a Windows library.

Another thing you can do is create an "override"
  1. Open PlayOnLinux
  2. Click configure
  3. Go To Wine Tab
  4. Click Wine Configuration
  5. Click Libraries Tab
  6. Enter:  comctl32
  7. Click Add
There are a few options with builtin, native and disable.  So you may have to trial-n-error those until it works.

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
rhalina Sunday 6 April 2014 at 12:24

thanks for your reply :)

I tried to install CivV via PlayOnLinux (step-by-step-click-through). Within in PlayOnLinux I installed d3dx9 and vcrun2008.

I'm trying to understand the issue with MicrosoftCommonControls, but as my last step into the Windowsworld has been 10 years ago....

Also fiddling around with the overrides of comctl32.dll did not really change things.

Any others ideals?

booman Monday 7 April 2014 at 16:05

nope, guess you could post a bug on AppDB about it.
You might be treading new ground here. There are only a few trying to play CivV in Linux and are having the same issue.
If you eventually find a solution, please post here for the community.

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained