The forum

Post 2012 Version of Sims 3 - Origin

issues instaling

Author Replies
bazsound Monday 21 April 2014 at 22:22

I've just repaced my copy of sims 3 due to disc damage and lost license key. I dont have a good internet connection so downloading an iso is out of the question, which was why i bought a new game.

Unknown to me that the game had been updated after 2012 which now requires Origin.

No choice in the matter.

Problem is that the game will not install from the CD, and then after that it tries to download which also fails

If i cant get it working ill just have to take it back and demand a refund.

Has anyone successfully gotten origin to install sims 3 from the disc.  I tried loading it from the disc using sims3setup.exe. It says preparing installtion but then an error pops up something about invalid install directory.

Have tried creating a new directory as the directory that was in the defualt was non existant, but that produced same error.

bazsound Tuesday 22 April 2014 at 13:00

Okay ive finally managed to get origin to play nicely by using the version of wine specificaly for origin,

howveer im sure this is likely not to play nicely with sims.

Me previous sims however did work nice without using any install script, im sure i installed it manually and it worked fine so heres hoping it does.
bazsound Wednesday 23 April 2014 at 0:19

Sims 3 finished installing but origin still says its installing. Prety much stuck at 100%

Al the files are there, but origin still thinks sims is installing despite the sims3 installer finishing.

This is on kx studio 12.04 (ubuntu based distro)

does anyone have any idea if this version of sims is able to work on linux, or should i be demanding that EA give me a copy of the old version without origin
bazsound Wednesday 23 April 2014 at 11:13

I'm having one more bash at this, tried latest version of wine.

Origin instaled fine, loaded fine, sims again installer ran copied all the files and finished. But origin still sat there with "installing" Under the sims 3 photo while at the bottom of origin the bar was sitting there 100% and not going away.

Clicking on the sims 3 box photo play button was there, clicking play done nothing.

And again origin would not close due to thinking its still installed. There must be a way to tell origin that the game finished installing as it has, the files as there and you can run them.

Going back to origin version of wine and installing some extra libraries, ones that i believe are installed via using playonlinux install script and also a few extras like service pack 2 which the sims 3 box says it needs, and full dx9 dontnet wininet etc.

No wonder people pirate software. I could have downloaded a cracked copy of the older version of sims 3 which works instead of wasting £20 and 4 days of headbanging
booman Wednesday 23 April 2014 at 20:51

Some good tips on WineHQ's about Origin
There is a trick to the downloader stuck at 100% but I havn't done it myself.

Manual installation is a good idea and it sounds like you are doing  everything right.

If you still can't get it to run with the WineHQ tips, might as well use a "no-CD" crack to run the game.  You purchased it legally and own it, so no harm in that.

† Booman †
Mint 19.3 64-bit | Nvidia 450 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Wednesday 23 April 2014 at 20:51

I've had problems with Origin myself... games won't even start downloading on my Mint 16 Cinnamon.
But I was able to install it and browse games, etc.

Edited by booman

† Booman †
Mint 19.3 64-bit | Nvidia 450 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
bazsound Thursday 24 April 2014 at 10:10

Booman thanks for the link to wineHQ, i had a look on wineHQ but couldnt seem to find origin,

think i may have found a solution!!!

"At the end of a game installation, it may stall at 99%. Wait for some time for your HDD to stop working (indicating the installation is done) and kill EAProxyInstaller.exe. The game should immediately become ready to play."

bazsound Thursday 24 April 2014 at 14:03

Thanks for all the suggestions, the problem with this version of the game is that sims 3 wont install without origin.

The no CD installer ive tried through POL origin setup crashes when using the Sims 3 script.

I dont think the no cd patch woud work with this version since it relies on origin, even with the game installed running ts3.exe or ts auncher opens origin.

Thanks for the suggestions, i finally got the game to install properly and work!

I had to complelty delete all installations i had, manually deleting the virtual drivers. I reinstalled Origin with wine 1.5-origin. Manually ran the setup file within origin, sims installed and went to the usaul 100% complete aked if i wanted to inform ea of gamepay etc clicked next and nothing. still say installing.

Gave it a while to ensure it was done.

Opened ksysguard, ended the process EAproxyinstaller.


Ready to pay, it wanted to download updates which turned out to be 6gb. some update sounds like the whole entire game. Fuck that. Canceled updates.

Clicked play and the launcher came up. Ignored the update, ast time i tried this it froze.

The launcher is very slow, but the game has loaded up and running.

Ive not tested it as i dont play it its my GF that plays, but
bazsound Wednesday 30 April 2014 at 12:09

Seems that sims 3 with origin is working fine. A little slow to load games on my machine (but my machine is an ald athlon 64 xII 2ghz) gameplay is fine, no noticble bugs.

And so far it hasnt crashed.

Its just a shame that you cannot launch the game without the launcher. The launcher is slow. Without the launcher i could launch the game in its own x server but since the launcher needs a window manager you cant do that.

trying to launch ts3.exe results in wine crashing.