The forum

Certain programs hang with 100% CPU on recent kernels

Specifically affects Quicken 2001 and wineboot.exe

Author Replies
PaddyLandau Thursday 17 July 2014 at 15:04


I have a strange problem. Up to kernel 3.13.0-24, I have been able (for years) to run my Quicken 2001 program on PlayOnLinux. This has been great.

However, with every kernel since then (currently 3.13.0-32), when starting Quicken with PlayOnLinx, it hangs. The process wineboot.exe takes 100% of one of the CPU's. It sits there like that until I cancel the process (which I can do by pressing Close from the PlayOnLinux screen).

This is consistent. When I boot my machine with kernel 3.13.0-24, Quicken starts up from PlayOnLinux within seconds, but when I boot with any later kernel, wineboot.exe hangs on 100% CPU.

I have tested this on both Ubuntu and Lubuntu. In fact, I am using Lubuntu in a virtual machine with the older kernel in order to be able to use Quicken without having to reboot my machine each time.

Here are more details:

  • Name of the distribution (and its version):
    Ubuntu 14.04 64-bit

    Lubuntu 14.04 64-bit
  • Name of the software and its version (ex: Wine 0.9.37):
    Wine 1.6.2-0
    PlayOnLInux 4.2.4 (Ubuntu)
    PlayOnLinux 4.2.2 (Lubuntu)
  • Your desktop (KDE, Gnome, Xfce, Fluxbox...):
    Unity (Ubuntu)
    LXDE (Lubuntu)
  • Errors from the software. And if possible, tell when and where it happens.
    wineboot.exe hangs with 100% CPU moments after starting the program, only on kernels later than 3.13.0-24 and only for Quicken 2001.
    Note that I can start a different program (Publisher) without problem.
  • Your computer configuration.
    The Ubuntu and Lubuntu machines both have a standard set-up.

I would have tried running Quicken directly from Wine if I knew how! I use PlayOnLinux precisely because I don't know how to use Wine.

One extra point: Ubuntu did not release kernels 3.13.0-25 and 3.13.0-26, so for all I know it might have been able to work on them. I have no way to test this.

If you can help me please to diagnose and fix this issue, I would be most grateful. I'll be happy to follow instructions.

Thank you.

PaddyLandau Saturday 27 December 2014 at 17:49

It works now. I don't know which update solved it.