The forum

Wine version "System" missing from config drop down

Author Replies
u83rmensch Thursday 31 July 2014 at 22:37

A little bit of back story. I run fedora 20 w/ KDE and use a plugin called verromix ( it is a desktop widget). Veriomix makes it quick and easy for me to configure the audio setting of my various programs that are open and producing sound including but not limited to switching the device its outputting to and the volume. Only problem is using it with Play on Linux. Longer story short, I found through testing that kmix and verromix will only display programs running in wine when I use the "System" version of wine in play on linux, if I use any other version of wine provided by the Play on linux wine manager, they will not show up in the audio list on my system. 

on to the problem I ran into yesterday:


I was trying to load up Counter Strike: Global Offensive. I dont know what I did but something caused it to not launch any more (after having ran it many times with little to no issues). I thought maybe getting the latest version of wine would help. Play on linux is great like that, I can test the version of wine with the program before commiting my system version. 

after testing wine version .1.7.23, and found that it had no effect on the CS:GO launch i went to change back to "System" however it was no missing from the drop down. I thought maybe I overloaded the amount of version of wine the drop down could show and started to remove older versions I no longer needed or used. This made no difference and "System" was still missing. 

time to hit up google: either my google-fu was off or no ones had this problem or at least no ones reported it if they have. 

now is when I try to start doing things in minor panic. I removed the steam PoL drive and attempted to reinstall it. That had no effect either, after reloading steam all the same options from the drop down where still there. that got me thinking that there must be a config file or directory that is not getting deleted or changed after having removed said "drive". 


fastward toa bit of tinkering around I found a file named "playonlinux.cfg" under :


contents of this file included: 


I compared this file to a .cfg file that did have the "system" option still in its dropdown menu and found that the "VERSION=" line was completely missing entirely. I backed up the file and did the same. Upon restart PlayOnLinux, the "System" option was set on my steam drive and launching games or apps from it shows in my audio mixer which tells me it is infact using the system wineprefix.


Strangly should I switch from System to any other version of wine, and try to go back to "System" by pulling down the drop down menu, the option I get under the drop down says "installing" opposed to "System" and the .cfg file shows "VERSION=installing" opposed to "System". It seems to still be using the "system" version of the wineprefix though when launching steam/games 


any who. that was my find and im putting it out there incase any one else needs to find a fix for this. 


booman Thursday 31 July 2014 at 23:04

Thanks for the tips and information.
I honestly never use "System" because it is inherited from the intial Wine installation.  Updating it would probably be a pain, so I always stick to creating new virtual drives and using downloaded versions of Wine.

I see why you use it because of your custom audio setup.

One day Wine and PlayOnLinux will use Pulseaudio so we don't have to do all of these "work-a-rounds"

† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
u83rmensch Thursday 7 August 2014 at 20:13

to tell you the truth, I meant to post this on play-on-linux.. after looking this up, just now realizing its on the play-on-mac page.. and frankly it probably wont do many mac users much good as im sure less than .5% of mac useres have raw wine installed with out cross over or play on mac. can this be linked to play on linux forum or should I repost it? 

Edited by u83rmensch

booman Thursday 7 August 2014 at 21:05

I think the administrators can move it to playonlinux forums

† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained