The forum

PoL League of Legends DirectX Error

Author Replies
FernandoM Friday 26 September 2014 at 23:25

I have installed league of legends using PlayOnLinux and used the following guide.

Everytime I start a game the screen goes black, then goes back to normal with the following error.

"An unknown DirectX error has occured and League of Legends cannot start. Please make sure your video card is using the latest video drivers from the manufacturer."

I tried installing drivers for my video card using the following guide. But I still get the same problem.

I have tried editing the game.cfg file which determines if the game should go into full screen mode or not but everytime I edit the file a new game.cfg file is made by League of Legends and replaces the edited file that I made. Also the game.cfg file league of legends uses does not have all the data it normally has.

Game.cfg contents:

I have tried changing the display settings to openGL, fbo, and different memory sizes since i'm not sure how much memory my integrated graphics card has.

I have tried installing some directx packages from a different guide I found as well as some wine libraries but that didn't work either.

I have installed windows 8 on this laptop and I managed to run League of Legends just fine so I know its at least possible to run league of legends on this laptop. Below are my laptop specs.

OS: Ubuntu 14.04 LTS 32-bit
PoL Ver: 4.2.5
CPU: Intel® Celeron(R) M CPU 520 @ 1.60GHz
Graphics Card: Intel® 945GM x86/MMX/SSE2


booman Wednesday 1 October 2014 at 1:31

Can you confirm the Intel video drivers are installed?  That forum guide was for Ubuntu 12.04, so it may not work for Unbuntu 14.04

I have a feeling the black screen is due to a driver problem or conflict.

Try searching for Driver Manager and see if it shows that Intel proprietary video drivers are installed.

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
FernandoM Wednesday 1 October 2014 at 6:04

So I couldn't find the "Driver Manager" when searching in Ubuntu. I assumed you ment the Mint Driver Manager so I installed that using the following guide.

After I installed and opened the mind driver manager I found that only one proprietary driver showed up and it was for the wireless lan controller.

I am unsure if the intel drivers are installed at this point since the intel graphics card does not show up on the driver manager.

booman Wednesday 1 October 2014 at 21:16

I forget what its called in Ubuntu, but they one you installed is fine too.

I'll have to look up how to install proprietary drivers for Intel GPU's in Ubuntu.  I mostly use Mint, but it shouldn't be much different.

Search for Linux Graphics Installer in Ubuntu 14.04

If its not there try this:  Linux Graphics Installer

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
FernandoM Friday 3 October 2014 at 21:44

Okay so it turns out I did install those linux graphics drivers before. I installed them again but they still do not show up in the driver manager. League still doesn't get past the black screen.

I am also having other problems with linux now. Linux never completely shuts down properly so I have to hold the power button in order for it to turn off now. I am considering re-installing linux and trying to install league of legends again at this point.

booman Friday 3 October 2014 at 21:54

That is a good idea.  Something must be corrupt or conflicting.  You can always try using the Terminal to shutdown and it might give you some errors


sudo shutdown -h now

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained