The forum

League of legends on ubuntu

no ingame menus

Author Replies
Purrro Tuesday 21 October 2014 at 21:07

Hi everyone!

I have been playing LOL for some time now on my ubuntu laptop..

There WERE some problems along the way but i always managed to find a fix from someone else who had the same problems.

Now I am facing a problem I didn't see anyone else that have it..

It started with the new patch i guess.. I haven't played for a few month and when i came back it updated the launcher and the game.. 

first problem was that i couldn't even open the game.. that got fixed by installing the newest wine-lol version.

2nd was that i couldn't login.. was fixed by deleting a .dll file.

3rd i can login and start a game but as soon as i tried to open the shop (just the shop.. everything else was ok) the game immideatly crashed. - that was fixed by adding a line to the config file..

now i can update, login, start a game but i have no menus.. that means when i press esc or tab or P for the shop (also just clicking with mouse on shop) it makes the sound like its opening it but nothing happens.. it's as if it is transperent or dislocated from screen.. i can't press on the field and do stuff just as expected from an open menu but there is nothing there..

everything else is working good and i can play and lvlup my skills and everything.


Thank you very much for your help!

petch Wednesday 22 October 2014 at 0:43

Purrro Wednesday 22 October 2014 at 20:20


I did add a x3d line in the config.. that helped me not crash my game when opening the shop..

but now there are no menus.

petch Friday 24 October 2014 at 8:11

I asked because it does the same for me

Purrro Sunday 26 October 2014 at 16:03

So i guess there is still no fix for that huh? :(
Too bad i can't do anything to help fix it but only wait...
petch Sunday 26 October 2014 at 17:56

On my two test systems, LoL works out of the box after installation using the script


Purrro Monday 27 October 2014 at 9:24

Using what script?
petch Monday 27 October 2014 at 13:27

The PlayOnLinux script to install League of Legends.

Basically I install LoL on both systems with Install button > Games > League of Legends

Edited by petch

Purrro Monday 27 October 2014 at 17:34

Hmmm.. i did that too but no menus.. i'll try to do it again
PoTski Friday 14 November 2014 at 14:46

Dude. theres no ingame shop cause of your x3d_platform setting.


remove that and try. if the game crashes then you need to find another workaround. Prolly different GPU drivers.