The forum

Blank install list without errors

Author Replies
IconoclasTripod Saturday 13 December 2014 at 22:42

Hello to anyone reading this,


I'm having an issue with playonlinux,


after months using it without any problem, suddenly the install list is completely blank, making it impossible to install anything. I tried refreshing, I tried selecting a category, nothing.


I then tried searching this forum but no one has the same problem : they either have an error with their internet connection or have the POL offline plug-in enabled.


In my case launching POL from the command line gives nothing out of the ordinary :

iconoclastripod@Peacemachine:~$ playonlinux
rm: cannot remove `*': No such file or directory
[install_plugins] Message: Checking plugin: Offline PlayOnLinux...
[install_plugins] Message: Checking plugin: Capture...
[install_plugins] Message: Checking plugin: Transgaming Cedega...
[maj_check] Message: List is up to date
[install_plugins] Message: Checking plugin: Wine Import...
[install_plugins] Message: Checking plugin: Wine Look...
[install_plugins] Message: Checking plugin: Screen Capture...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
[maj_check] Message: List is up to date

As you can see by the last line, pressing "refresh" triggers a message saying that the list is up to date.


I tried removing, cleaning and reinstalling but the same problem arrises, even though I took care removing the .PlayOnLinux folder in my home.


What is especially weird is that is spent the day installing games in preparation for a trip and it is just now that this problem arises.


I'm running Ubuntu 12.04 and the latest POL in the official depots for precise, that is 4.0.14, thanks by advance for any help.


Edited by IconoclasTripod

petch Saturday 13 December 2014 at 23:39


PlayOnLinux 4.0.14 is now 3 years old, and is no longer supported.

Current version is 4.2.5, newer versions have interface improvements including graphic subsystem self tests, easier access to debug logs, not to mention 3 years worth of bug fixes; And the dev team is way too small to keep supporting all the versions that appeared inbetween.

Listing has been broken for a while today, it has been quickly fixed for current version but not for your old version; This just got fixed after your message, but only because it was an easy fix. You may not be so lucky forever.

To keep it short: upgrade to 4.2.5

IconoclasTripod Sunday 14 December 2014 at 0:20

Alright petch, thanks for the reply, I actually didn't know there existed a separate playonlinux depot, distinct from the distro ones. I had the last version from my official ubuntu depot. I added the POL depot and upgraded and everything works fine. 

Now I know, and knowing is...