The forum

PA audio fix figured out, advice on making it clean.

Author Replies
schotty Sunday 4 January 2015 at 1:20
schotty

OK.  A friend I nagged into getting into linux got me off my duff to figure this one out, and I am almost done.

 

Pulseaudio and wine do not play well together as we all know.  So for some time I figured out that all my issues can be resolved with a change in the /etc/pulse/daemon.conf and a variable for wine.  The former is easy, the latter is where I need a hand.

 

The parameter at hand is used as follows:

export PULSE_LATENCY_MSEC=60
playonlinux

Now what I have been doing is just running a shell script to keep this working.  My friends however are not that tech saavy.  Is there a place from within PoL to plop this in to make it take effect?  Doing this for each bottle is kosher.

 

Thanks

Andrew.

Ronin DUSETTE Sunday 4 January 2015 at 17:42
Ronin DUSETTE
Admin

I have heard so much bad about pulse and wine, but I have never had any issues. I even run jack and wineasio through pulse and have no issues. 

You can prefix commands to execute before running the program. Look in the Configure menu, in either the general or misc tab. There is a field that appears when you highlight your game in that field where you can enter commands.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
schotty Sunday 4 January 2015 at 19:22
schotty

OK, I found what You Were talking about, and Added in the stuff and it worked great!

Here is a screenie for anyone else That wants help doing this:

http://www.schotty.com/storage/images/pol-wow-extra-parameters.png

Thanks a bunch!

Edited by schotty

Ronin DUSETTE Monday 5 January 2015 at 21:33
Ronin DUSETTE
Admin

No problem. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
iiwii Saturday 10 January 2015 at 11:19
iiwiiAnonymous

This works for my headphone issues :-)

xpander Saturday 10 January 2015 at 16:19
xpander

yes for JACK+Pulse

though i never had issues with pulse since 2008 as well

Ronin DUSETTE Sunday 11 January 2015 at 19:12
Ronin DUSETTE
Admin

Yup. Same here. I have never, ever had any issues with Pulse since I started using Linux. Not through Wine, not in practice, not ever. I actually really like Pulse. I don't see where issues start happening. Maybe it is with specific sound cards? Idunno.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts