The forum

Arguments too long - Help

My last hope is here

Author Replies
seba2122 Tuesday 31 March 2015 at 13:43


After searching on the web and endlessly trying to make it work, I can't pass this argument:

let's call it arguments:

"8394" "LoLLauncher.exe" "" "spectator v2gldShviD3cFTio3+kUrgo5+zEFJigk 1822264920 KR"

to "League of legends.exe" (let's call it app(string including quotes))

that is located in:

let's call it linux-path:

~/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends/RADS/solutions/lol_game_client_sln/releases/

let's call it pol-path:

C:\Riot Games\League of Legends\RADS\solutions\lol_game_client_sln\releases\0.084\deploy

Now, using terminal in linux.

I tried following:(Cd'd to linux-path)

playonlinux app <-- it works yay but not correctly because no parameters were used
playonlinux app arguments <-- There is nothing installed to run .8394 files.

playonlinux 'app arguments' <-- There is nothing installed to run .com:80 v2gldshvid3cftio3+kurgo5+zefjigk 1822264920 kr" files.

playonlinux --run app arguments  <-- no "app" found <-- I know why but just saying what I tried

using "wine" instead of playonlinux gives me a massive xrand error even before anything can start so YEAH

now, going to PlayOnLinux->League Of Legends->Configure-> wine ->Console

cd'ing all the way to pol-path

and trying the following:

start app <-- it works yay but not correctly because no parameters were used

But if I try to do such thing:(copy and paste the arguments )

C:\Riot Games\League of Legends\RADS\solutions\lol_game_client_sln\releases\0.0.1.
84\deploy>start "" "League of Legends.exe" "8394" "LoLLauncher.exe" "" "spec
Application could not be started, or no application associated with the specified
ShellExecuteEx failed: File not found.

it doesn't execute it. TOO LONG!

so then I thought: LET's to it .bat way

so I created a bat file containing:

start "" "League of Legends.exe" "8394" "LoLLauncher.exe" "" "spectator v2gldShviD3cFTio3+kUrgo5+zEFJigk 1822264920 KR"


and then started it with "start filename.bat" i got:

C:\Riot Games\League of Legends\RADS\solutions\lol_game_client_sln\releases\0.0.
1.84\deploy>start "" "League of Legends.exe" "8394" "LoLLauncher.exe" "" "specta
tor v2gldShviD3cFTio3+kUrgo5+zEFJigk 182226492
0 KR"
Application could not be started, or no application associated with the specifie
d file.
ShellExecuteEx failed: Invalid parameter.

C:\Riot Games\League of Legends\RADS\solutions\lol_game_client_sln\releases\0.0.
Press any key to continue...

But surprisingly if I open task manager(from PoL config menu), and click "New task..." and start an app like this:(copied from "open")

C:\Riot Games\League of Legends\RADS\solutions\lol_game_client_sln\releases\\deploy\League of Legends.exe "8394" "LoLLauncher.exe" "" "spectator V7YxYK/sBUSvEGhCqdh5qJZf8rxtb/mG 1822150133 KR"

it works perfectly fine.

Cool... cool... but I want it to be able to run from a script, where no human actions are needed.

the wine version selected in playonlinux is 1.7.33-LeagueOfLegends2

Linux: Ubuntu 14.04

PlayOnLinux 4.2.2

Plz help :<

Edited by seba2122

petch Tuesday 31 March 2015 at 19:34

What should work:

Configure button > (select LeagueOfLegends virtual drive) > "Make a shortcut from this virtual drive" button

Select LeagueOfLegends.exe, call the shortcut as you like (say, "LoL Spectator")

Configure button > (select the shortcut LoL Spectator) > General tab > Arguments >

8394 LoLLauncher.exe "" "spectator v2gldShviD3cFTio3+kUrgo5+zEFJigk 1822264920 KR"

Now you can start your program by double-clicking on the LoL Spectator shortcut.

And to run it from scripts,

$ playonlinux --run "LoL Spectator"


Edited by petch

seba2122 Tuesday 31 March 2015 at 19:47

very nice idea but the arguments are ever changing.

The arguments are needed to start spectator mode in League of Legends for a certain match and if the match ends another one must start and I won't get it from your method.


Arguments = changing all the time = flexible script = command line execution

petch Tuesday 31 March 2015 at 20:42

Then use the "~/.PlayOnLinux/shortcuts/LoL Spectator" script as a scripts template and run them with playonlinux-bash


petch Tuesday 31 March 2015 at 20:50

After some experimentation, playonlinux-bash could be another way to pass more than one argument;

Make a shortcut like above, without tweaking the arguments, then run

$ playonlinux-bash ~/.PlayOnLinux/shortcuts/"LoL Spectator" "8394" "LoLLauncher.exe" "" "spectator v2gldShviD3cFTio3+kUrgo5+zEFJigk 1822264920 KR"


seba2122 Tuesday 31 March 2015 at 22:28

Thank you petch. The problem is solved and the arguments can be executed. Thank you!


To be honest I was looking at shortcuts but I didn't do anything with them because I didn't know that they work in such a way.


Thanks again!