The forum

Failure to install Photoshop CS6 or Illustartor CS6 using PlayOnLinux 4.2.10

Author Replies
diogenes_of_sinope Saturday 11 February 2017 at 22:14

Good evening.

I've tried to install both Photoshop and Illustrartor using the Play on Linux package available in Debian's stable repository, and I was unsuccessful. Soon after, I tried to perform the instalation with Debian's testing repository version as well. In both cases the installation was unsuccessful, and ttendue to the same error, although for the "testing" version I've gotten two additional lines of warnings "[Check_OpenGL]" as well. As such, I'll transcribe here the response I've gotten from trying to install it using the testing version:


Looking for python... 2.7.9 - wxversion(s): 3.0-gtk2
[main] Message: PlayOnLinux (4.2.10) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Warning: check_dd_x86 missing, test skipped
[Check_OpenGL] Warning: check_dd_amd64 missing, test skipped
[POL_System_CheckFS] Message: Checking filesystem for /home/thoreau/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
[update_check] Message: List is up to date
[POL_SetupWindow_Init] Message: Creating new window for pid 679
[POL_SetupWindow_Close] Message: Closing window for pid 679
[POL_GPG_auth_script] Message: Checking signature of /home/thoreau/.PlayOnLinux//install
[POL_GPG_install_key] Message: Importing PlayOnLinux public key
[POL_Bash] Message: POL GPG : Good signature - Adobe Photoshop CS6
[POL_SetupWindow_Init] Message: Creating new window for pid 901
[POL_SetupWindow_browse] Message: browser answer: /home/thoreau/Installers/Photoshop_13_LS16/Adobe CS6/Set-up.exe
[POL_Wine_SelectPrefix] Message: Selecting prefix: PhotoshopCS6
[POL_System_SetArch] Message: POL_ARCH set to x86
[POL_Wine_PrefixCreate] Message: Setting POL_WINEVERSION to 1.7.46-staging
[POL_Wine_PrefixCreate] Message: Creating prefix (1.7.46-staging)...
[POL_Wine_PrefixCreate] Message: Prefix already exists
[POL_SetupWindow_menu] Message: menu answer: Overwrite (usually works, no guarantee)
[POL_Wine_PrefixCreate] Message: Overwrite Prefix
[POL_Wine_PrefixCreate] Message: Setting version to 1.7.46-staging
[POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.7.46-staging
/usr/share/playonlinux/lib/wine.lib: line 986: /home/thoreau/.PlayOnLinux//wine/linux-x86/1.7.46-staging/bin/wineserver: No such file or directory
[POL_LoadVar_PROGRAMFILES] Message: Getting Program Files name
[POL_Wine] Message: Running wine-1.7.46-staging cmd /c echo %ProgramFiles% (Working directory : /usr/share/playonlinux/python)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See
/usr/share/playonlinux/lib/wine.lib: line 568: /home/thoreau/.PlayOnLinux//wine/linux-x86/1.7.46-staging/bin/wine: No such file or directory
[POL_Wine] Error: Wine seems to have crashed


From a layman's point of view, the error seems to be at the second to last line of the code, when the address "/home/thoreau/.PlayOnLinux//wine/linux-x86/1.7.46-staging/bin/wine: No such file or directory" is called with an additional "/" in between "/.PlayOnLinux" and "/wine". Be that as it may, I wouldn't know how to change the programs's behaviour in that regard anyway.

With nothing more to add, let me thank you, for taking the time to read my concerns.