The forum

Cannot change wine version

Author Replies
clickz Wednesday 12 July 2017 at 2:22

My system: Debian Jessie and PoL 4.2.10

As I understand, the error I'm presenting is not game related but PoL related, please bare with me the explanation of the whole issue if you're happy to do so.

League suffers (I believe) memory leaks, thus the FPS dramatically drop as the games last longer. In my case from about 120fps to 15fps at ~ min 30. This is using the standard 1.9.2-LeagueOfLegends5 wine. This issue is from the client, not the loader, and I have tried this before the new client came up already, but it has gotten worse lately.

I read in some reddit post that using a staging version, and enabling CSMT could solve the issue for some people, so I wanted to try. The PoL configuration window allowed me to download and install all wine versions (including said staging versions), but they could never run. This particular example is the debug I get from 1.9.2-staging-LOL3, but other versions would give the same error:

[07/12/17 00:55:27] - Running wine-1.9.2-staging-LOL3 LeagueClient.exe (Working directory : $MY_HOME/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends)
wine: failed to initialize: //lib/wine/ cannot open shared object file: No such file or directory

I cannot even go to the configuration of the installed wine, or install libraries for that matter, it also bugs there.

The installation folder for the new wine versions, does include the library, I.e:


Installing a newer PoL version did not help, so I've reverted to the PoL I can find in pip (4.2.10). Reinstalling wine gave me no results either.


TLDR: I can only use the wine version that my game comes with. Other wine versions do not run and complain about missing (which apparently is in the right place).


chatbott Wednesday 12 July 2017 at 17:46

Unrelated to your current issue, capping the fps in the options menu of league of legends fixed the framerate issue for me and other people. You can check if you need league of legends help on linux

Edited by chatbott

clickz Wednesday 12 July 2017 at 20:32

Thanks for the framerate cap suggestion, it definitely made my game smoother.

I'm still unable to say why I cannot install other wine versions.

clickz Monday 9 October 2017 at 15:15

I used this to solve the problem with my wine installations:

My PoL was installing wine versions with a relative path to the lib folder which was not accessible, due to some facts I yet fail to understand. The solution is to modify those paths in the wine/wineserver binaries.

(this is just a copy/paste from the solution)

$ cd ~/.PlayOnLinux/wine/[ARCH]/[VERSION]/bin
$ patchelf --set-rpath $(pwd)/../lib wine
$ patchelf --set-rpath $(pwd)/../lib wineserver
ImperatorS79 Monday 9 October 2017 at 15:32

And is League of Legends fully working now ? What wine version are you finally using ?



PS : You could give a try to the POL5 script (I do not know if it is working) ? ->

POL5 is here ! ->
clickz Tuesday 10 October 2017 at 15:07

Yes, chatbott's suggestion was good enough to play league for me, and I am using that for a couple of months now. My setup is 1.9.2-LeagueOfLegends5, with framecap at 60fps (defined ingame), which stays constant throughout the game.

Nonetheless I was just sharing the solution I found for the more general topic I started here. I came back to the same problem (I was unable to use other wine versions) when I tried to install another program through PoL. Fortunately I was able to solve it, and I decided to share the steps in case someone else finds it helpful.


BloodyIron Wednesday 11 October 2017 at 18:45

Why don't you try a much newer version... like... I dunno... 2.18-staging?

I've found that it solves so much of the problems, like these, with League. Try it out?

clickz Friday 13 October 2017 at 22:51

I've tried 2.18-staging but the loader gets stuck before rendering the wallpaper and it becomes non responsive.