The forum

Controller issue with Mudrunner under Steam

Author Replies
Quaxo76 Sunday 20 May 2018 at 1:13

Hello, I'm running a freshly-installed version of PlayOnLinux, version 4.2.12. Wine is version 2.12-staging. My operating system is Kubuntu 18.04.

I've installed Steam, and it appears to work. Under Steam I have installed the game "Spintires:Mudrunner", which loads and runs fine, but I have an issue with the controller. I use a generic pc-only xbox-style controller ("nacon" brand, model GC-100XF), which works perfectly with Steam under Windows. But when I run the game with Steam under Linux, the controller isn't seen as a xbox controller, but as a wheel; i.e. if I go to the Controls page of the game, on the tab "Controllers", I get "Controller 1 - not connected", but I can see the controller on the "Wheels" tab. But configuring it as a wheel, I can not add all the commands that can be used if it's configured as a controller, thus preventing me from playing the game correctly.

Is it known why it is seen as the wrong kind of device, and is it possible to make the game see it properly as an xbox-like controller?

I have already tried with both the xpad and xboxdrv modules, with the same result (both work, but both show the same issue).

I have tried going to the "Settings -> Controllers -> General controller settings" page on Steam, but it crashes with the error

DWrite.dll is missing, please check your Windows/DirectX installation.


Thank you in advance,


ImperatorS79 Monday 21 May 2018 at 13:09

I think the controller support in wine is through SDL2, and unfortunately wine versions in pol are not build with SDL2 yet ->

POL5 is here ! ->