The forum

Windows programs installation hangs

Problem with wine interface maybe?

Author Replies
Matchgirl42 Thursday 14 February 2019 at 21:49



I did do some research in the forums but didn't find any post specific to this problem.

I'm new to Linux - the Windows 10 crap gave me the final push I needed to switch - and I just installed Linux Mint on a brand new Dell laptop.  I'm not dual booted; Linux Mint is the only OS on the laptop, I got rid of Windows 10 completely because I hated it immediately.  And I chose Linux Mint because it was the closest to Windows 7, which I loved.

Here is my system info:

Operating System: Linux Mint 19.1 Cinnamon

Cinnamon Version: 4.0.9

Linux Kernel: 4.15.0-45-generic

Processor: Intel Core i3-8130U CPU @ 2.20GHz x2

Memory 7.7 GiB

Hard Drives 960.4 GB

Graphics Card Intel Corporation UHD Graphics 620

I've also gone into the update manager and I'm fully updated, that's one of the first things I tried to fix this issue.


Using the Software manager, I installed PlayOnLinux 4.2.12-1.  It installed just fine.  But when I try to install windows-based software - and I've tried it with both Civ IV complete (DVD-ROM) and Internet Explorer 7 and 8 - the installer just hangs.  I've let it run for 4 hours each time thinking it might just need time, but it never completes the install and I have to cancel it out.  But then when I try to reinstall, it says that I have to overwrite the virtual drive, and in the PlayOnLinux configuration menu, virtual drives for both Civ4 and IE7 (the last one I tried) appear.  But I can't launch either one, because they don't appear in the main PlayOnLinux screen.

I think it might be a wine problem because I can see a WINE icon in the bottom tray, and when I hover the mouse over it, a small preview box appears above the icon and it says "choose default language."  But clicking on the box does nothing.  Trying to launch WINE independently does nothing.

I did go through the PlayOnLinux configure screens to configure WINE, and installed several versions.  But now when I try to go back in to configure WINE, the WINE configure box will pop up with the dots going in a circle symbol for about 5 seconds, then will close out on it's own without allowing me to see or do anything.

I'd really prefer to not have to do a complete wipe and fresh Mint install.  I've tried uninstalling PlayOnLinux, purging all WINE versions, then reinstalling, via several methods: The Software manager, PlayOnLinux, and the terminal.  Nothing seems to fix whatever the problem is.

I did try to register for the WINE forums to ask over there as it seems it might be a WINE issue, but I couldn't get past the question thing to prove I'm not a robot, because I'm new to Linux, and don't know the answers to those questions (like the first name of one of the softare managers?) and couldn't find the answer with a google search.

Help me Obi-Wan, you're my only hope?

Jack_Bauer Saturday 16 February 2019 at 2:13


You're not alone... I have exactly the same problem on PlayOnLinux (4.2.12)...

  • OS: elementary OS 5.0 (Juno)
  • Kernel: x86_64 Linux 4.15.0-45-generic
  • CPU: Intel Celeron N2920 @ 4x 1.9995GHz
  • GPU: Mesa DRI Intel(R) Bay Trail
  • RAM: 7.7 GiB

I try to install the game (GOG HOMM3 Complete) and it stuck at the installation process when creating the virtual drive.

Thanks for your help!

Quentin PÂRIS Saturday 16 February 2019 at 16:18
Quentin PÂRISAnonymous


Try to update to POL 4.3.4 and use a recent wine version. It should fix your problems

Matchgirl42 Sunday 17 February 2019 at 0:14

Hrm.  Well, there was an improvement.  Sort of.  Actually, that's not correct.  It just got hung up at a different point in the process.

I deleted PlayOnLinux and all the versions of WINE, then installed POL 4.3.4 from the terminal (the 4.2.12-1 version is the one available on the Linux Mint Software Manager, 4.3.4 isn't on there.  And I couldn't find a menu option in the 4.3.12-1 version to update.) (I installed the "Trusty Version" because I figured that would be the best bet).  It installed well, and using it's "Manage Wine Versions" tool, I installed WINE 4.3

Then I tried to use POL 4.3.4 to install Internet Explorer 8.

It actually got farther before it hanged, but it still hanged.  I also noticed it was trying to install an earlier version of WINE.  Looking in my wine versions manager, there were about 4 different, earlier versions of WINE installed.

I now have two WINE icons in the system tray - one just says "wine" and the other says "Wine Mono Installer" in the preview panes, but just like before, clicking on them does nothing.

I closed those two WINE instances out, removed the earlier versions of WINE using the POL manager, and tried to install IE8 again.

It once again tried to install earlier versions of WINE, and got hung up, and I had to cancel it out.  It also popped up the two WINE icons in the system tray again, same as before.  But when I closed out the Wine Mono Installer, another one popped up that reads "Wine Gecko installer."  When I closed that instance, the "wine" icon disappeared on it's own.

Looking in POL manage wine versions, on the x86 side, it shows WINE 1.7.22.

Matchgirl42 Sunday 17 February 2019 at 0:17

I just removed the WINE 1.7.22 from the x86 side, installed WINE 4.3 on the x86 side, then tried to install IE8 again.  Same thing happened.

Quentin PÂRIS Sunday 17 February 2019 at 10:35
Quentin PÂRISAnonymous

Please retry

Matchgirl42 Monday 18 February 2019 at 4:58

Okay, I retried all the steps, got the same exact results.

Then I figured I'd try the steps outlined in the final reply here:

I also followed the instructions here to manually install WINE mono from the terminal:

Then I reinstalled POL again, and managed to get IE8 to install and run.  (Hooray!  One down.)

However, when I tried to install Civ IV complete from the DVD-ROM, it's still hanging.  After some investigation I realized that what's causing it to hang is what I thought - when POL tries to install WINE gecko, that's what's hanging and fouling up the install.  And for some reason, even though it's already been installed manually via the terminal, POL tries to install WINE mono and it also hangs and fouls up the Civ IV install.

I tried searching for instructions to manually install WINE gecko but just got links to .msi files (, and clicking on them just brings up a "launch application" box with no application options.  I tried to follow the instructions here ( to manually copy the .msi files (I grabbed both of the latest ones, the x86 and the x64), but my system won't let me paste anything into the wine folder.

I did do a google search for "install gecko via terminal linux" but didn't find anything useful.

So it's what I thought initially: for whatever reason, the POL interface to install WINE is messed up.

Matchgirl42 Monday 18 February 2019 at 5:00

Should I try installing using the .deb file instead?  Or one of the other 5 versions via the terminal besides the trusty version?

Matchgirl42 Saturday 23 February 2019 at 12:49

So technically this isn't playonlinux, but I did want to report that, since I couldn't actually get POL to run the IE that I installed, I've been searching for a solution to be able to print coupons from home (which is the only thing I wanted it for), and multiple failed attempts to set up a dual boot for Win 7 and 3 re-installs of Linux mint, I found a solution that is so simple I'm mad I didn't find it sooner: using the User-Agent Switcher add-on in Firefox. This allows firefox to fool the site into thinking i'm running IE on Windows. Yay! I can print coupons now!

Still working on getting CIV IV complete installed, trying to figure out how to do it without using POL, because I have yet to get past the point where it hangs on the WINE installations, even after the fresh install of Linux Mint. But until the wine installation/management interface in POL gets fixed, or I or someone else can figure out what it is about my system that's causing it to mess up, I'm giving up on POL for now.
Matchgirl42 Saturday 23 February 2019 at 14:15

Well now here's some interesting info that I just disovered today, and I'm including it here for posterity...

I also play Runescape, and one of the first pieces of software I installed via the software manager is the linux Runescape client.

And with WINE stable, WINE 64 and winetricks installed, when I open the Runescape client, it opens and keeps open two windows - the loading screen, and the main client window.  And the game client is choppy/laggy, both fps/gameplay and also music tracks and sounds.

But when I removed WINE and winetricks completely from my system, the game client only opens the loading screen for a few seconds, then the main client window opens and the loading screen closes.  And the game runs completely smoothly.

Including this here in case it provides any clues for anyone looking into this.