The forum

New diablo 2 gameplay error after upgrading to Deb 10

Author Replies
ogsarticuno Sunday 24 November 2019 at 22:08
ogsarticunoAnonymous

Greetings.  Yesterday, I upgraded from Deb 9 to 10.  Following the upgrade, I lost wired and wireless internet communication which was eventually fixed after modifying some network manager settings and updating my drivers. 

After doing this, I updated POL and though I can start and play Diablo 2, trying to sign into battle net causes a crash.  This is a widely reported issue when trying to run D2 with certain versions of wine.  However, using other  versions under POL seemed to prevent this issue, and before my upgrade I usually did not have this issue (could just rerun if it crashed and eventually it would work).

I have pasted my debug output below.  I'm thinking that perhaps (i) something happened to my internet settings on upgrade (see DHCP message below) or (ii) after the update some file or variable is not properly being identified.

edit: apt install of winbind removed some of the debug errors but still having trouble.  It mentioned something DHCP connection settings that I can modify in some file.  Perhaps this is key,.

LMK if y'all can think of anything, have experienced something similiar, or can provide help.

Here is my debug output:

Running wine-4.7-staging Diablo II.exe -w (Working directory : /home/cnb49/.PlayOnLinux/wineprefix/DiabloII/drive_c/Diablo II)

004a:fixme:thread:RtlCreateUserThread stack_reserve != 0 is unimplemented
0057:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
0057:fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
0057:fixme:wbemprox:wbem_locator_QueryInterface interface {00000126-0000-0000-c000-000000000046} not implemented
0057:fixme:thread:RtlCreateUserThread stack_reserve != 0 is unimplemented
[2019-11-24T21:35:12Z][..\source\main.cpp:690][INFO]: System Survey 2.3.1.44, Data Version 3, Git Revision v2.3.0.42-20-ge49c7e7, Copyright (C) 2013 Blizzard Entertainment. All rights reserved.
[2019-11-24T21:35:12Z][..\source\main.cpp:764][INFO]: Exit value: 0
0063:fixme:process:GetProcessWorkingSetSizeEx (0xffffffff,0x3d1cc18,0x3d1cc14,(nil)): stub
0063:fixme:ntdll:EtwRegisterTraceGuidsW (0x3e86d58, (nil), {f7b697a3-4db5-4d3b-be71-c4d284e6592f}, 7, 0x3ed0244, (null), (null), 0x3ed5ca8): stub
0063:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {72b14a7d-704c-423e-92f8-7e6d64bcb92a}
0063:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {e2091f8a-1e0a-4731-84a2-0dd57c8a5261}
0063:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {e8a3bf1f-a86b-4390-9c60-5390b969d22c}
0063:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {5727a00f-50be-4519-8256-f7699871fecb}
0063:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {7e854ec7-cdc4-405a-b5b2-aaf7c9e7d40c}
0063:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {79a60dc6-5fc8-4952-a41c-1163aeec5eb8}
0063:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {2718d25b-5bf5-4479-8e88-babc64bdbfca}
0063:fixme:process:GetNumaHighestNodeNumber (0x3d1cab8): semi-stub
0065:fixme:thread:RtlCreateUserThread stack_commit != 0 is unimplemented
0053:fixme:dbghelp:elf_search_auxv can't find symbol in module
006c:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
006c:fixme:heap:GetPhysicallyInstalledSystemMemory stub: 0x32f218
006c:fixme:heap:GetPhysicallyInstalledSystemMemory stub: 0x32f218
006c:fixme:ntdll:NtQuerySystemInformationEx Relationship filtering not implemented: 0x3
006c:fixme:ntdll:NtQuerySystemInformationEx Relationship filtering not implemented: 0x3
006c:fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
006c:fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported

Edited by ogsarticuno

Dadu042 Monday 25 November 2019 at 11:53
Dadu042
Moderator

All I can say is that the current script uses Wine 4.5