The forum

Using POL 4.3.4 on MINT 18.3... and TLJ will not create virtual drive and install...

Author Replies
flatiron Saturday 4 January 2020 at 12:25

So when I try to use the stock installer from POL for The Longest Journey, it hangs at the point where it says it is creating the virtual drive. I can see that it's created the virtual drive in the POL folder, but it hangs there and will not proceed. I have tried clicking on that debugging icon to see what is going on, but the debugging window will not pop up.


With the older version of POL (I forget which) I was using it would always hang on the point where it was downloading winXP... if that matters any.

flatiron Saturday 4 January 2020 at 12:37

For some reason installing Directx9 causese POL to crash..... while it's being installed.

flatiron Saturday 4 January 2020 at 13:44

Using the "non listed program" install option... it installed. But when I tried to play the game there was no sound and the video wouldn't show... I just got my desktop displayed at a very low resolution where most of the desktop was off screen.


Which is funny, because earlier when I tried this there was sound. Now the device that I used to have to select to get sound is not available as an option.

flatiron Saturday 4 January 2020 at 13:46

Well, now when I look the proper audio device shows.


How do I download XP for this program? Also, does this game need dx9's? I tried installing them but it did no good.

Dadu042 Sunday 5 January 2020 at 3:40

- How do I download XP for this program? : POL does just simulate it.

- Also, does this game need dx9's? -> usually no (from Wine v2 or 3).

- I have upgraded (-> 3.0.3) the Wine version used in the script of this game, this should help you.

Edited by Dadu042

flatiron Sunday 5 January 2020 at 10:30

Dadu042, what do I do with that script (the stuff in that box, right?)? I have little knowledge of how to program linux... actually, I have no knowledge of how to program linux.

Dadu042 Sunday 19 January 2020 at 20:16

Just use it, POL and POM does auto update about that.

flatiron Saturday 25 January 2020 at 0:46

Oh, just use wine 3.03... okay.

flatiron Saturday 25 January 2020 at 1:09

Seems to work (as well as it used to anyway)! Thanks!


And I should let you know. I installed it as a non listed program. I also used the newer installer which has an updated language pack and uses a seperate bin file with the brunt of the game data with the exe file being small for whatever reason...


But it works!

flatiron Saturday 25 January 2020 at 1:21

I spoke too soon. I could sift through my save, but when I clicked on one nothing happened but a tiny box with gear in the upper left corner appeared.... but the in game sound could be heard, just the screen was still stuck on the save select screen... the following debug error appeared a while after.

0036:fixme:win:EnumDisplayDevices ((null),0,0x32e018,0x00000000), stub!


I just downloaded all dx9's to see if it will work.

flatiron Saturday 25 January 2020 at 1:33

I downloaded all the dx9's and it didn't change anything. I get the same effect if I click on start new game except with little box of gears in the upper left corner.. Video just stays on the home menu while the sound works as it should.


I also discovered that turning off 3d acceleration just gives me a white screen and force me to do a hard restart.


Did you just update 3.03 or 3.03 and newer?

flatiron Sunday 26 January 2020 at 1:45

I seem to have encountered a game breaking bug where the boy that is supposed to drop the pizza carton in the trash can just after April goes to the upper levels of Newport in chapter 11... he never appears. So I cannot proceed with the game...

Other important notes:

Okay... so I found out that, while using 3.03, and maybe 1.3.32-tlj2 that if I hit print screen to go back to the desktop, then click the game to bring it back up, then the actual game shows on screen and I can play it.

1.3.32-tlj2 doesn't work anymore though. April is invisible in it for example

I discovered that 4.21 works fine though.

For a while there for some reason whenever I selected the audio menu under "wine" then "configure wine", it would give me an error. Now it doesn't do that anymore but the audio menu has changed. It used to show many devices. Now it just has "default" or "pulse" I think, as options. But the audio works in 4.21 and 3.03.

Also, now whever I update the wine version and then start the game, it gives me this little "updating" rectangle, but the rectangle will not go away, and the update doesn't seem to complete until I restart the computer.

Edited by flatiron

flatiron Sunday 26 January 2020 at 4:17

Okay, so the game breaking bug wasn't a bug. It was just the result of the game maker being an asshole.


Apparently you're supposed to give the star map to "the flipper"... all with no hints at all. Once I did that the pizza box appeared and I was able to dupe the receptionist.


So the game works now.

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to