The forum

"gdi32.dll" failed to initialize on xubuntu 20.04

Author Replies
brunoais Monday 3 May 2021 at 19:43

Linux version: xubuntu 20.04.2

Version de POL: playonlinux_4.3.4-1ubuntu1

Full computer specs: AMD 4800H, 16GB


 - Running wine-6.4 --version (Working directory : /home/me/.PlayOnLinux/shortcuts)

PlayOnLinux logfile
Date: 05/03/21 

> PlayOnLinux Version
> uname -a
  Linux host 5.8.0-50-generic #56~20.04.1-Ubuntu SMP Mon Apr 12 21:46:35 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
> lsb_release -a
> wine --version
> Distribution
  Ubuntu 20.04.2 LTS
> glxinfo \| grep rendering
  direct rendering: Yes
> glxinfo \| grep renderer
      GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_query_renderer, GLX_MESA_swap_control, GLX_OML_swap_method,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: AMD RENOIR (DRM 3.40.0, 5.8.0-50-generic, LLVM 11.0.0)
> OpenGL libs (Direct rendering testing)
  check_dd_x86 missing, test skipped
  check_dd_amd64 missing, test skipped

[] - Running wine-6.4 cmd /c echo %ProgramFiles% (Working directory : /home/me/.PlayOnLinux/shortcuts)
002c:err:module:DelayLoadFailureHook failed to delay load shell32.dll.SHGetFolderPathW
wine: Call from 7B0100F2 to unimplemented function shell32.dll.SHGetFolderPathW, aborting
wine: Unimplemented function shell32.dll.SHGetFolderPathW called at address 7B0100F2 (thread 002c), starting debugger...
002c:err:seh:start_debugger Couldn't start debugger L"winedbg --auto 40 72" (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
0024:err:module:LdrInitializeThunk "gdi32.dll" failed to initialize, aborting
0024:err:module:LdrInitializeThunk Initializing dlls for L"C:\\windows\\system32\\cmd.exe" failed, status c0000005
0040:err:module:LdrInitializeThunk "gdi32.dll" failed to initialize, aborting
0040:err:module:LdrInitializeThunk Initializing dlls for L"C:\\windows\\system32\\conhost.exe" failed, status c0000005

I already tried with other WINE versions such as 6.5 and 5.22.
I also tried rebooting and reinstalling. Both reinstalling WINE and reinstalling PlayOnLinux

What am I missing here?

Dadu042 Friday 18 March 2022 at 0:10

All I know is: prefer Wine X.0 branches.   Perhaps the 6.4 was bugged or ours had a compilation issue.

DrM1173 Sunday 20 March 2022 at 12:03


All I know is: prefer Wine X.0 branches.   Perhaps the 6.4 was bugged or ours had a compilation issue.

Do you mean that the X.0 branches are the stable branches of Wine?

Dadu042 Sunday 20 March 2022 at 22:59

Yes, these are the stables.