The forum

WoW installation

Author Replies
karizma Saturday 13 December 2008 at 11:53

Hello All,

New user to linux and to POL and i'm trying to install this popular game to show others that their favorite past time addiction will work on Linux.

Currently running Ubuntu 8.10
Wine version 1.0.1
Running Gnome
Laptop Specs

My issue:

My problem is that I cannot install WoW: Burning Crusade.

I've gotten the first release of WoW installed but when I use POL to install the burning crusade it cannot find the previous installation of WoW. I went through the process of copying all the CD's using the scripts a few times to make sure it wasn't a user error. However, after the copying The Burning Crusade says: Please install World of Warcraft before installing The Burning Crusade and gives me options to exit installation, view user manual or other options that have nothing to do with actually installing the game.

Please help!! Would love to see this work and convert some people to linux!

Edited by karizma

daev Tuesday 5 July 2011 at 12:50

duddy11 Thursday 4 August 2011 at 22:10

Hello. I think I can help you out. I have been having some problems trying to get WoW to install to, but I found a way around it. If you have a windows system that will help greatly too, but you grab VirtualBox and use that, make sure you have a file shared to your vb. Go ahead and download the WoW client from, and run it and let it download. Once it get's to playable, then close the program and VB and go to your shared folder and make sure the WoW has been downloaded most of the ways..

- Then go to PlayOnLinux --> Install --> World Of Warcraft --> select digital copy ---> then when it asks you for the install file, browse to your WoW Directory and select launcher.exe.
-Minimize your WoW Window and let it continue downloading
-Go to your WoW folder again, make a Link to it by right clicking, go to "Make Link".
-Cut and paste that linked folder into your ~/.PlayOnLinux/wineprefix/WorldOfWarcraft" folder. Delete any other folders that are named World Of Warcraft then paste it in there.. Once that is done go to your shortcut that was placed on the desktop, and under command, put this --> env WINEPREFIX="/home/ilyas/.PlayOnLinux/wineprefix/WorldOfWarcraft" wine C:\\\\Program\\ Files\\\\World\\ Of\\ Warcraft\\\\launcher.exe
-Of course your WINEPREFIX path will be wherever you have your wine installed.

That worked for me. Hope this helps you get your WoW Up and Running.

Geodomus Wednesday 10 August 2011 at 16:17

just a small hint for you... you dont need to install an Addon, EVER. Simply activate it in your B.Net account, and WoW will do the rest.

Addon's are ALLWAYS installed with the patches (2.0.0, 3.0.0, 4.0.0 etc). No need to ever install from a CD, just let the game patch, and you are good to go.
Bmanplus2 Friday 19 August 2011 at 10:04

Hello all let me start out by saying even if I cannot get this to work This is an awesome idea and program.

I have a similar problem but yet different

I am running Ubuntu 11.04

POL 4.0.4

and WINE 1.3.26 and 1.2.1

I am trying to get wow to work for my little brother, I got the main game installed using the cd's and now am trying to get burning crusade to work from the downloaded WoW-4.0.0-WOW-enUS-Installer.exe which is the bulk pack of wow and bc all in one.

The error I am getting is when I click on install and then the bc game, it then asks me for the install method and I select digital download version and navigate to WoW-4.0.0-WOW-enUS-Installer.exe and hit next. It starts saying that its prepping the install and then I get an error saying unable to connect please check your connection and firewall settings (it said this before with the plain wow without the cd's)

Please If anyone has some free time I would really appreciate some help.
Thank you all
Geodomus Friday 19 August 2011 at 17:07

you MIGHT need openSSL for this, had a simmilar Problem with the Starcraft 2 patcher.

might be a hint, but im not totally sure.

Best bet is to launch it from the debug console and upload the output
Bmanplus2 Friday 19 August 2011 at 21:00

Thank you for your time, Sadly I am dumb I went into terminal and apt-get'ed openSSL and it said that it was already the newest version but I cannot find it in the computer I do not know how to run pol in the debug console at all

Again thank you so much for the response, I am so lost
Geodomus Saturday 20 August 2011 at 22:32

if apt-get says openssl is there, then its there and everything is fine.

If you have a Windows-PC, download the game there and copy it over to the Linux machine, it works if you do it that way.

thats the only advice I can give you at the moment...
Bmanplus2 Monday 22 August 2011 at 5:06

sorry for being a pain in the butt would you be willing to walk me through this. If not its cool but yea I do not know what I am doing here
Geodomus Monday 22 August 2011 at 21:01

1) copy the folder from windows to linux
2) open launcher.exe with wine ;)

it should be that simple, i never tried WoW though...

It works with Starcraft 2, and WoW was portable as well, so there's a good chance this works^^
Dimplewidget Saturday 10 September 2011 at 18:16

WoW has no necessary registry hooks, so copy and paste is a valid method for backup and transfer of the game. I just hate that WoW has dropped opengl support.