The forum

Hellgate Global

RawInput again

Author Replies
Geodomus Sunday 7 August 2011 at 19:07

So... I was trying to get HG:G to work, and moving around works quite well, but the mouse wont work. Are you guys able to make a wine version with the RawInput patch?

Because i dont get it working somehow.
GNU_Raziel Sunday 7 August 2011 at 20:08

This patch is no longer needed since wine-1.3.21 (if I remember right), as long as you have an up-to-date installation.

If you're using an Ubuntu/Mint OS and do not have latest (or patched one), you can add x-swat ppa to update to latest version, it's easy to find on the web.
Geodomus Sunday 7 August 2011 at 20:14

2 Things then:

a) I cant move the mouse because of an outdated Xorg, do i get this right?

b) if thats the case, my F15 didnt say anything of an update for Xorg, and google gives me virtually no hits on howto update.

Any help appreciated.
GNU_Raziel Sunday 7 August 2011 at 21:05

Yes you're right and I don't know about any F15 update. You must, at least, have a patched v7.5 or vanilla v7.6 installed to avoid using this old wine patch.

You can also try, forcing mouse to "stay" in the game, using Advanced Wine Configuration plugin to set MouseWarpOverride setting to Force. This will probably disable any mouse use in game's menus, but can also solve your problem.

Edited by GNU_Raziel

Geodomus Sunday 7 August 2011 at 21:44

ok, the force wont work.

Also, i cant update it to 7.6, it seems... Fedora says its X is 1.10.3.
Geodomus Tuesday 9 August 2011 at 16:21

ok, so i set up Kubuntu and used the swat PPA with's latest version.... the mouse still wont work
GNU_Raziel Tuesday 9 August 2011 at 16:47

If it still bug, then it's another bug affecting this game with wine, xinput2 support is not faulty. Make sure you use at least wine-1.3.25 for this game.

Try to add dinput8 using PlayOnLinux Functions (Installation->Others) and it's still not enough set the mouse override again.
Geodomus Tuesday 9 August 2011 at 20:25

Neither dinput8 nor xinput fix that bug... im still not able to look around...
Geodomus Tuesday 9 August 2011 at 23:17

I've logged the start and uploaded it, maybe this helps
You are here: Index > PlayOnLinux > Hellgate Global