The forum

Unable to install StarCraft II

Author Replies
kmrajax Sunday 28 August 2011 at 16:44

Hi everybody!

I am new at the forum and have some issues with StarCraft II. I couldn't find an answer to my problem so I try this way.

First i tried to install SC II by using the digital Download.
Here's what I did: (POL version: 4.0.9)

1. Went to battlenet and downloaded the installer
2. Opened POL and clicked "install" and selectet "StarCraft II: Wings of Liberty"
3. Wizard opened and installed the right Gecko
4. Selected "Use a setup file in my computer"
5. Select the digital download file
6. The Blizzard Downloader starts to download the game
7. After like an hour the downloader closes with no error in POL or the terminal. I tested this several times and it crashed moments every time.

Then I tried to install it with the DVD.

Step 1 - 3 is just the same

4. Selected "Run from DVD"
5. The DVD is mounted (I can go into the DVD folder without problems)
6. The list with mount points appears and here i get confuesed. Sometimes the SC II DVD is in the list and sometimes not. Though whatever i select here it's allways the same issue; The PlayOnLinux wizard just stand "thinking"... nothing happens. I have let it be in this moode for several hours without any results.

Can someone please help?
IMPORTANT: I have sucessfully installed SC II in the earlier versions of POL.

Best regards

Geodomus Sunday 28 August 2011 at 21:02

download the setup before installing it. That way it will definitley work
kmrajax Monday 29 August 2011 at 12:55

download the setup before installing it. That way it will definitley work

Quote from Geodomus

Hi Geodomus!

Actually i kinda thaught that it was the setup i was downloading when it crashed? May I ask exactly how I should do this? Maby I missing something here.

Thanks for the reply!

kmrajax Monday 29 August 2011 at 14:13


I tried to install my copy of Diablo II with digital download and i get the same issue:
The Blizzard Downloader suddanly dissapears after about twenty minutes without any error messages. :/
kmrajax Monday 29 August 2011 at 20:45

Hi again!

Problem is solved. The issue was Internet Explorer 6:
I did like this:

1. Created a new virtual drive
2. Installed IE 6 on the drive
3. Installed StarCraft II on the drive. (Without the script)

This time it worked flawless.