The forum

Baldur's Gate 2 - "no CD present"

Author Replies
MrLeek Saturday 17 December 2011 at 22:56

Hi all

Been puzzling over this one for a couple of days now. I've used the PoL script to install BG2 (worked just fine), but when it came to actually running the game I got the "CD is not inserted" message - despite having the CD in the drive.

Easy to just go down the no-cd "patch" route...but since I'm trying to learn scripting and how things are trying to work to get these games to work in Linux I started digging for an alternative solution.

Still not got this to work - but here's what I've looked at:

- Pointed the D: at the correct mount of the BG2 disk via winecfg - still get the same error.
- The script copies all the disks to a temp directory by the looks of it. When you examine the BG2 directory after install there's four directories called "CD2", "CD3", etc.Meanwhile the baldur.ini file has this section:

HD0:=C:\\Program Files\\Black Isle\\BGII - SoA\\
CD1:=C:\\Program Files\\Black Isle\\BGII - SoA\\CD1\\
CD2:=C:\\Program Files\\Black Isle\\BGII - SoA\\CD2\\;C:\\Program Files\\Black Isle\\BGII - SoA\\CD2\\
CD3:=C:\\Program Files\\Black Isle\\BGII - SoA\\CD3\\
CD4:=C:\\Program Files\\Black Isle\\BGII - SoA\\CD4\\
CD5:=C:\\Program Files\\Black Isle\\BGII - SoA\\CD5\\

A double typo on the CD2 line right? Removed that - no joy. But there's no "CD1" directory either....puzzling!

So I tried to point D: at the CD2 directory via winecfg - again, no joy.

So I'm stuck! From my reading I know that a lot of this is down to WINE struggling with copy protection. But I can't see how to fix the problem either....

Any ideas folks? Thanks!

Edited by MrLeek