The forum

OpenGL and Steam Games

Author Replies
papalcontroller Tuesday 27 March 2012 at 21:20


How do I go about editing the Registry to make steam games run on OpenGL?
papalcontroller Sunday 1 April 2012 at 14:38

To rephrase my question: I want to run a particular steam game using OpenGL, as that might improve performance. How do I go about doing it?

Is there a command for the terminal to run steam games in OpenGL? The problem is, individual steam games are not listed as 'applications' under POL, so I have to 'install' them as 'applications' before I can run them using terminal.

So, the other solution seems to involve using the Registry to make a game run using OpenGL. How do I do this?
DAVVVVE Sunday 1 April 2012 at 19:35

Just mark the exefile , press configure . Under display , just change direct draw renderer to open gl . If that do the trick .
papalcontroller Monday 2 April 2012 at 19:29


When I go to my program folder (cossacks ii battle for europe), and select the exefile, right click, there isn't a 'configure' option available... how?
papalcontroller Wednesday 11 April 2012 at 21:36

Does anyone know if there is a command in terminal for running an exe file using playonlinux and opengl?
Drowz0r Thursday 12 April 2012 at 20:58

This is a big issue for me.

I've recently installed a game that makes use of OpenGL.dll for dynamic lighting yet the game seems to only render in D3D mode.

The game is Cry of Fear - a recent mod but for the original Half-Life 1 engine.

The game is only supported in OpenGL mode. When I run it in OpenGL mode, although the game "believes" it's rendering in OpenGL mode, it is missing some of the dynamic lighting which is called from then OpenGL.dll file

This is apparently a clear way to see if your game is running in D3D or OpenGL mode.

Additionally some hue effects appear when you're in D3D mode instead of OpenGL mode and I see those too - so everything points to it rendering in D3D dispite me changing the settings to OpenGL - no one running the game in Windows XP/7 is having this issue so I suspect it's something to do with the virtual drive? I've tried different versions of wine 1.3~ 1.4~ 1.5~ and tried running it in Windows XP/7 mode but there has been no change.

If anyone knows a way to perhaps "force" rendering in OpenGL mode I'd love to know it!

Ubuntu 16.04 LTS
8GiB RAM | Intel 3.20 Quad Core CPU
GeForce GTX 750 Ti/PCIe/SSE2 | Dual 4.3 (5:4 res) 19" screens